Crash when using Find in Page

RESOLVED FIXED in Firefox 47

Status

()

--
critical
RESOLVED FIXED
3 years ago
3 years ago

People

(Reporter: armenzg, Assigned: khuey)

Tracking

({crash, crashreportid})

Trunk
mozilla47
Unspecified
All
crash, crashreportid
Points:
---

Firefox Tracking Flags

(e10s?, firefox47+ fixed)

Details

(crash signature, URL)

Attachments

(1 attachment)

(Reporter)

Description

3 years ago
Since Monday 25th, I'm experiencing all my tabs crashing at once multiple times a day.

I'm running on Linux, using Nightly, only JSONView as my active add-on.

This would generally happen when pastebin or treeherder would be loading.

https://crash-stats.mozilla.com/report/index/2e3c9c03-cc50-4dc1-91e6-fccfe2160201
https://crash-stats.mozilla.com/report/index/5ed4df72-fd46-448b-ba4a-a30952160201
(Reporter)

Comment 1

3 years ago
I have noticed that if I try to search in the page it will consistenly crash all my tabs.

Raising to major.
Severity: normal → major
tracking-e10s: --- → ?
Duplicate of this bug: 1245014

Updated

3 years ago
Component: Find Toolbar → General
Product: Toolkit → Core
Version: unspecified → Trunk

Updated

3 years ago
Crash Signature: [@ nsTypeAheadFind::FindItNow ]
Has STR: --- → yes

Updated

3 years ago
Summary: All my tabs have been crashing recently → Crash when using Find in Page
Trying to find a regression range.
Severity: major → critical
Flags: needinfo?(mconley)
Keywords: regressionwindow-wanted
I can't seem to reproduce this on my Ubuntu VM. jdm, if you have a sec, if you're able to reproduce this reliably, do you think you can mozregression us a range? I figure this has got to be pretty recent.
Flags: needinfo?(mconley) → needinfo?(josh)
(In reply to Milan Sreckovic [:milan] from comment #6)
> I hit this twice today, but now can't reproduce on demand:
> https://crash-stats.mozilla.com/report/index/d49a898b-ad50-4717-ac5f-
> 0e7d12160203
> https://crash-stats.mozilla.com/report/index/1f5a6b0a-0897-4f89-ae66-
> 39c542160203

These on OS X.

Comment 8

3 years ago
Reproduced on windows
https://hg.mozilla.org/mozilla-central/rev/f2f8fc172f4c62334e9a92bcf10e00fe877387d5
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:47.0) Gecko/20100101 Firefox/47.0 ID:20160203030249
OS: Unspecified → All

Comment 9

3 years ago
bp-3a8bfe8b-2411-4028-b100-4b2282160203
Crash Signature: [@ nsTypeAheadFind::FindItNow ] → [@ nsTypeAheadFind::FindItNow ] [@ nsPIDOMWindow<T>::GetDocShell]

Comment 10

3 years ago
¡Hola!

FWIW Some steps that crash reliably here.

Steps:
Load https://pastebin.mozilla.org/8858453
Press <Ctrl>+<F>
Type "QuitProgressUI"
Click down arrow until the search cycles to the top

Result:
Tab crashes

Expected result:
Top most search result is highlighted

¡Gracias!
Thanks for the STR! Those work for me.

My instinct puts my suspicions on bug 1241764.

Using mozregression - stand by...
Flags: needinfo?(josh)
Here's the regression range:

https://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=584870f1cbc5d060a57e147ce249f736956e2b62&tochange=b2a3dc4b161fdfac6db78cc5bbfb1f53a383b65a

Hey khuey - I suspect your work in bug 1241764 caused this... do the stacks make that plausible?


[Tracking Requested - why for this release]:

Pretty easy-to-hit crash regression.
Blocks: 1241764
tracking-firefox47: --- → ?
Flags: needinfo?(khuey)
Keywords: regressionwindow-wanted
Created attachment 8715483 [details] [diff] [review]
Patch
Assignee: nobody → khuey
Status: NEW → ASSIGNED
Flags: needinfo?(khuey)
Attachment #8715483 - Flags: review?(bugs)
Component: General → DOM

Comment 15

3 years ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/9fecb5ee050f
Status: ASSIGNED → RESOLVED
Last Resolved: 3 years ago
status-firefox47: --- → fixed
Resolution: --- → FIXED
Target Milestone: --- → mozilla47
(Reporter)

Comment 16

3 years ago
Looking forward to the next nightly! Thanks for the fix!

Is there a test that could have caught this?
If I understand the STR from comment 10 correctly, then an automated test that does a Find Bar search that hops over iframes would probably have caused the crash to appear in automation.

As it stands, I don't believe we have such a test - though I'd be happy to mentor somebody in writing one.
(Reporter)

Comment 18

3 years ago
I would be happy to learn. It might take a bit of time and I'm going in pat leave in March but if possible I would love to learn.
tracking-firefox47: ? → +
(Reporter)

Comment 19

3 years ago
I filed bug 1247948 separetely.
You need to log in before you can comment on or make changes to this bug.