Closed Bug 12448 Opened 20 years ago Closed 20 years ago

Error loading pages with whitespace before DOCTYPE

Categories

(SeaMonkey :: General, defect, P3)

x86
Linux
defect

Tracking

(Not tracked)

VERIFIED DUPLICATE of bug 10878

People

(Reporter: bergie, Assigned: don)

References

()

Details

It seems that Mozilla (tested on build 1999082408 for Linux but present
also on at least some earlier builds) has problems loading a page that
has a DOCTYPE element if the element is not in the exact beginning of
the HTML page.

Builds 1999080212 and 1999082412 for Windows NT do not have this problem.

Here are some examples:

Successful one - DOCTYPE right in the beginning:

 Document http://www.midgard-project.org/article/1171.html loaded successfully
 Document: Done (9.171 secs)

 $ lynx -mime_header http://www.midgard-project.org/article/1171.html | head
 HTTP/1.1 200 OK
 Date: Wed, 25 Aug 1999 11:59:34 GMT
 Server: Apache/1.3.6 (Unix) PHP/3.0.12 Midgard/1.2
 WWW-Authenticate: Basic realm="Midgard"
 Connection: close
 Content-Type: text/html

 <!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.0 Transitional//EN"
                       "http://www.w3.org/TR/REC-html40/loose.dtd">

Erroneous one, a space before the DOCTYPE element:

 Error: Can't load: http://www.midgard-project.org/topic/171.html (80004005)
 Error loading URL http://www.midgard-project.org/topic/171.html
 Document: Done (0.751 secs)

 $ lynx -mime_header http://www.midgard-project.org/topic/171.html | head
 HTTP/1.1 200 OK
 Date: Wed, 25 Aug 1999 11:59:09 GMT
 Server: Apache/1.3.6 (Unix) PHP/3.0.12 Midgard/1.2
 WWW-Authenticate: Basic realm="Midgard"
 Connection: close
 Content-Type: text/html

  <!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.0 Transitional//EN"
                       "http://www.w3.org/TR/REC-html40/loose.dtd">

Erroneous one, empty line before DOCTYPE:

 Error: Can't load: http://linux.com/ (80004005)
 Error loading URL http://linux.com/
 Document: Done (0.779 secs)

 $ lynx -mime_header http://linux.com/ | head
 HTTP/1.1 200 OK
 Date: Wed, 25 Aug 1999 11:45:36 GMT
 Server: Apache/1.3.9 (Unix) PHP/3.0.12
 Connection: close
 Content-Type: text/html


 <!DOCTYPE HTML PUBLIC"-//W3C//DTD HTML 4.0 Transitional//EN">
 <!-- What are we? Transmeta? there are no secret messages hidden in the html.
-->

When we removed the whitespace for the page
http://www.midgard-project.org/topic/171.html it loaded without
problems. I elected not to provide a test case as the problem should be
quite obvious and easy to test.
Status: NEW → RESOLVED
Closed: 20 years ago
Resolution: --- → DUPLICATE
Marking duplicate.

*** This bug has been marked as a duplicate of 10878 ***
Status: RESOLVED → VERIFIED
QA Contact: leger → elig
Verifying as duplicate upon reading bugs; thanks, run2000. (Great bug report,
too!)
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.