[css-grid] grid-column and -row sizing in `grid-template` value not supported

RESOLVED INVALID

Status

()

Core
CSS Parsing and Computation
RESOLVED INVALID
2 years ago
2 years ago

People

(Reporter: Eric A. Meyer, Unassigned)

Tracking

({testcase})

47 Branch
testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

2 years ago
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.8; rv:47.0) Gecko/20100101 Firefox/47.0
Build ID: 20160130030240

Steps to reproduce:

1. Loaded up http://meyerweb.com/eric/css/tests/grid-template-shorthand.html
2. Observed the results in FF Nightly and Chrome.


Actual results:

In Firefox, the first test goes fine.  In the second, where grid column and row sizing and grid line names are mixed in the `grid-template` shorthand property’s value, Firefox completely botches the layout.


Expected results:

The #g2 test should be laid out identically to the #g1 test.  This is the observed behavior in Chrome.

Updated

2 years ago
Component: Untriaged → CSS Parsing and Computation
Product: Firefox → Core
It looks like your example is still using the old "columns / rows" syntax.
The spec was changed so it's now "rows / columns".
https://drafts.csswg.org/css-grid/#explicit-grid-shorthand
After swapping the order the two grids is laid out the same.

We fixed this recently in bug 1240956 (note that the change in order
affects the 'grid', 'grid-template' and 'grid-gap' properties).

Please file a bug on Chrome if they haven't switched to the new syntax yet.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Keywords: testcase
Resolution: --- → INVALID
(Reporter)

Comment 2

2 years ago
Well, butter my buns and call me a side dish, so it has.  Thanks, Mats, and sorry for the erroneous bug report.  Off to file a Chrome bug!
You need to log in before you can comment on or make changes to this bug.