Closed Bug 1244893 Opened 4 years ago Closed 4 years ago

Disable F/OTA updates to balrog

Categories

(Firefox Build System :: Task Configuration, task)

task
Not set

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: selenamarie, Assigned: nhirata)

References

Details

Attachments

(1 file, 4 obsolete files)

Per bug 1232008, this bug is to disable our F/OTA updates. 

We have identified a way supporting F/OTA updates going forward identified in bug 1244181.
Here's a patch; I still need to test.  Wanting to get feedback to see if I'm on the right path or if I should make modifications to the approach.

Test build : https://tools.taskcluster.net/task-inspector/#L27Fpbz8RASBixxD_eUChA/

based on mach command : ./mach taskcluster-build --head-repo=https://github.com/nhirata/gecko-dev --head-rev=bug_1244893_disable_balrog --owner=nhirata@mozilla.com tasks/builds/b2g_aries_spark_dogfood.yml | sed -e 's/0\.0\.24/0.99.22/'
Attachment #8714655 - Flags: feedback?(wcosta)
Comment on attachment 8714655 [details] [diff] [review]
0001-bug-1244893-Disable-Balrog.patch

Review of attachment 8714655 [details] [diff] [review]:
-----------------------------------------------------------------

lgtm. As a follow up, we will have to remove the credentials from S3 (we = I).

::: testing/taskcluster/scripts/phone-builder/build-phone-ota.sh
@@ -27,5 @@
>  
>  $WORKSPACE/gecko/testing/mozharness/scripts/b2g_build.py \
>    --config $MOZHARNESS_CONFIG \
> -  --config $BALROG_SERVER_CONFIG \
> -  "$debug_flag" \

I don't think debug flag needs to be removed.
Attachment #8714655 - Flags: feedback?(wcosta) → feedback+
Patch fixed based on comment.
Attachment #8714655 - Attachment is obsolete: true
Attachment #8714879 - Flags: review?(wcosta)
Could you please run a try push?
Flags: needinfo?(nhirata.bugzilla)
Didn't they remove b2g from the tree?
If they didn't running try won't test the builds will it?

Oh I just realized I went too overboard though with the removal.
Flags: needinfo?(nhirata.bugzilla)
Attachment #8715562 - Flags: review?(wcosta)
Attachment #8714879 - Attachment is obsolete: true
Attachment #8714879 - Flags: review?(wcosta)
(In reply to Naoki Hirata :nhirata (please use needinfo instead of cc) from comment #6)
> Created attachment 8715562 [details] [diff] [review]
> 0001-bug-1244893-Disable-Balrog.patch
> 
> Didn't they remove b2g from the tree?

afaik, no.

> If they didn't running try won't test the builds will it?
> 

Just use -p all -t none -u none.

> Oh I just realized I went too overboard though with the removal.

What did you change in your patch?
Flags: needinfo?(nhirata.bugzilla)
I removed the - from 2 references to : 
       MOZHARNESS_CONFIG: b2g/taskcluster-spark-ota-balrog.py 
from my original patch.  Without those, it doesn't have a script to build... which would bust the build from building.  I put them back in.

The push to try in comment 7 ( https://treeherder.mozilla.org/#/jobs?repo=try&revision=209929a8aa6c ) uses : try: -b o -e -p all -u all -t none
is that good enough?
Flags: needinfo?(nhirata.bugzilla) → needinfo?(wcosta)
Comment on attachment 8715562 [details] [diff] [review]
0001-bug-1244893-Disable-Balrog.patch

Review of attachment 8715562 [details] [diff] [review]:
-----------------------------------------------------------------

lgtm, but notice the two tests with aries dogfood failed to build. Although the bustages don't relate to the patch, the balrog stuff was not tested. I recommend rerunning again.
Attachment #8715562 - Flags: review?(wcosta) → review+
Flags: needinfo?(wcosta)
Flags: needinfo?(wcosta)
It feels like no "-b do" flag was supplied.
Flags: needinfo?(wcosta)
(In reply to Wander Lairson Costa [:wcosta] from comment #12)
> It feels like no "-b do" flag was supplied.

Yes, no "-b do" based on based on comment 8.

resent with the -b do option : 
https://treeherder.mozilla.org/#/jobs?repo=try&revision=9b4fc432c7c4
Flags: needinfo?(wcosta)
(In reply to Naoki Hirata :nhirata (please use needinfo instead of cc) from comment #13)
> (In reply to Wander Lairson Costa [:wcosta] from comment #12)
> > It feels like no "-b do" flag was supplied.
> 
> Yes, no "-b do" based on based on comment 8.
> 
> resent with the -b do option : 
> https://treeherder.mozilla.org/#/jobs?repo=try&revision=9b4fc432c7c4

My bad, forgot to add the flag...
Flags: needinfo?(wcosta)
Thanks, Wander!  Yes.  I realize I need that flag.

Posting checkin-needed and pinging a sheriff for checkin.  :)
Flags: needinfo?(wkocher)
Keywords: checkin-needed
https://hg.mozilla.org/mozilla-central/rev/88735739af7a
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
backed out for problems like https://treeherder.mozilla.org/logviewer.html#?job_id=3283060&repo=mozilla-central that happend after this got merged to m-c
Status: RESOLVED → REOPENED
Flags: needinfo?(nhirata.bugzilla)
Resolution: FIXED → ---
this was backed out because of the empty "scope:" assignment in the debug and opt task definitions for spark aries ota.  I would remove that key entirely from the yml and it should be ok.
(In reply to Greg Arndt [:garndt] from comment #21)
> this was backed out because of the empty "scope:" assignment in the debug
> and opt task definitions for spark aries ota.  I would remove that key
> entirely from the yml and it should be ok.

Naoki, could you please update the patch?
Flags: needinfo?(wkocher)
Removed empty scope.
Attachment #8715562 - Attachment is obsolete: true
Flags: needinfo?(nhirata.bugzilla)
Comment on attachment 8720547 [details] [diff] [review]
0001-bug-1244893-disable-balrog.patch

Review of attachment 8720547 [details] [diff] [review]:
-----------------------------------------------------------------

Just on nit before r+.

::: testing/taskcluster/tasks/builds/b2g_aries_spark_ota_balrog_opt.yml
@@ -6,4 @@
>    payload:
> -    features:
> -      balrogVPNProxy: true
> -    env:

I think we should not remove env:, right?
ya.  you're right.
Attachment #8720547 - Attachment is obsolete: true
Attachment #8720547 - Flags: review?(wcosta)
Flags: needinfo?(wcosta)
Thanks for updating the patch, Naoki. I am going to test the patch next week.
Flags: needinfo?(wcosta)
Duplicate of this bug: 1250539
Comment on attachment 8721035 [details] [diff] [review]
0001-bug-1244893-disable-balrog.patch

Review of attachment 8721035 [details] [diff] [review]:
-----------------------------------------------------------------

https://treeherder.allizom.org/#/jobs?repo=try&revision=00bc02adacaf&selectedJob=17858598
Attachment #8721035 - Flags: review?(wcosta) → review+
Flags: needinfo?(wkocher)
https://hg.mozilla.org/mozilla-central/rev/a3837ca1b1c9
Status: REOPENED → RESOLVED
Closed: 4 years ago4 years ago
Resolution: --- → FIXED
Flags: needinfo?(wkocher)
Product: TaskCluster → Firefox Build System
You need to log in before you can comment on or make changes to this bug.