Closed Bug 12449 Opened 20 years ago Closed 20 years ago

{inc}incremental layout of generated content image

Categories

(Core :: Layout, defect, P3)

defect

Tracking

()

VERIFIED FIXED

People

(Reporter: dbaron, Assigned: troy)

References

()

Details

(Whiteboard: Waiting for next Linux build to check fix 8/27)

Attachments

(1 file)

DESCRIPTION:  The above URL has a p:before rule with content: url() of an
image.  When this image loads, it is placed incorrectly.  When the window is
resized or a reflow is triggered by stylesheet loading, the problem disappears.
(Also, when the image is at the incorrect position, it doesn't paint correctly
if I switch to another virtual screen and then switch back.)

STEPS TO REPRODUCE:
1) Load http://www.editions-eyrolles.com/livres/glazman/Tests/listes/listes2.htm
2) Click on "test suivant" (this is so the background image loads faster and the
last reflow is for the image)

ACTUAL RESULTS: Image placed incorrectly, possibly for just a flash, but often
until window is resized. (see screenshot)  At this position, it paints correctly
the first time, but not later times (window switching).

EXPECTED RESULTS:  Correct layout.

DOES NOT WORK CORRECTLY ON:
 * Linux, apprunner, 1999-08-24-08-M10
 * Linux, viewer, 1999-08-24-08-M10
You can see in the screenshot the image does not displace the text "Paragraphe
précédé d'une image" and that the image appears to low.  The baseline of the
image should be the same as the baseline of the text and the beginning of the
text should come after the image.
OS: Linux → All
Hardware: PC → All
In Windows 95 1999-08-24-09-M10, the generated content image doesn't show up at
all until I resize (just a slightly different painting problem, really).

Marking All/All.
Status: NEW → RESOLVED
Closed: 20 years ago
Resolution: --- → FIXED
Whiteboard: Waiting for next Linux build to check fix 8/27
I couldn't reproduce the problem described with Mac 8.6 (Aug 27 1999082712) and
Windows 95/98 (1999082616) builds. I need to wait for the next Linux build to see
if I can reproduce.
Status: RESOLVED → VERIFIED
Fixed in the the latest build (Sept 10).
You need to log in before you can comment on or make changes to this bug.