Closed Bug 1244912 Opened 4 years ago Closed 4 years ago

JSON Viewer: hide object summary when object is expanded

Categories

(DevTools :: JSON Viewer, defect, P3)

defect

Tracking

(firefox48 fixed)

RESOLVED FIXED
Firefox 48
Tracking Status
firefox48 --- fixed

People

(Reporter: clarkbw, Assigned: Honza)

References

Details

(Keywords: devtools-reload, Whiteboard: [btpp-backlog] )

Attachments

(1 file, 2 obsolete files)

When an object is expanded we should hide the collapsed object summary to prevent unnecessary duplicate information.

via bug 1223143 comment 7

> ## JSON tab - duplicate information when expanding an object
> 
> When an object is expanded, the object summary is still displayed, resulting
> in an unclear visual feedback, unclear hierarchy and duplicate information.
> 
> In the attached "duplicate-information.png" screenshot, the information
> "needsflag:false" is visible 3 times, but it’s only one data point.
Summary: JSON VIewer: hide object summary when object is expanded → JSON Viewer: hide object summary when object is expanded
Blocks: 1243951
Attached patch patch v1 (obsolete) — Splinter Review
Couldn't resist to fix one bug while testing the reload addon...
Attachment #8717957 - Flags: review?(odvarko)
Assignee: nobody → poirot.alex
Status: NEW → ASSIGNED
Keywords: devtools-reload
Sorry for the long delay!

Suggested patch works, but have an impact on any usage of the tree component. I am working on a generic tree (see bug 1247065) that supports nice customization and allows a better way how to solve this issue. That tree is just a step from landing and I'd like to give it a try and fix this properly.
If that doesn't happens soon (this week or so), I'll approve this patch.

Honza
Depends on: 1247065
Priority: -- → P3
Whiteboard: [btpp-backlog]
Duplicate of this bug: 1255842
Attached patch bug1244912.patch (obsolete) — Splinter Review
Sorry, it took so long, but I had to solve blockers first.

Patch attached.

- Do not render the summary when object is expanded
- Align toggle button + label to the top.

Honza
Assignee: poirot.alex → odvarko
Attachment #8717957 - Attachment is obsolete: true
Attachment #8717957 - Flags: review?(odvarko)
Attachment #8733371 - Flags: review?(jryans)
Attached patch bug1244912.patchSplinter Review
Include test coverage in the same patch.

Honza
Attachment #8733371 - Attachment is obsolete: true
Attachment #8733371 - Flags: review?(jryans)
Attachment #8733377 - Flags: review?(jryans)
Comment on attachment 8733377 [details] [diff] [review]
bug1244912.patch

Review of attachment 8733377 [details] [diff] [review]:
-----------------------------------------------------------------

Thanks for working on this!
Attachment #8733377 - Flags: review?(jryans) → review+
https://hg.mozilla.org/mozilla-central/rev/c96ec660af96
Status: ASSIGNED → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 48
Depends on: 1327306
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.