about:home button "Download", "Bookmarks", "History", "Addons", "Sync", "Options" and "Restore Previous Session" become 2 row (previously showed as 1 row)

RESOLVED DUPLICATE of bug 1244221

Status

()

Firefox
General
RESOLVED DUPLICATE of bug 1244221
2 years ago
2 years ago

People

(Reporter: coolkips, Unassigned)

Tracking

({regression})

44 Branch
regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

2 years ago
Created attachment 8714621 [details]
2_Rows.png

User Agent: Mozilla/5.0 (Windows NT 6.2; rv:44.0) Gecko/20100101 Firefox/44.0
Build ID: 20160123151951

Steps to reproduce:

Update Firefox from 43.0.4 to Firefox 44.0


Actual results:

about:home button "Download", "Bookmarks", "History", "Addons", "Sync", "Options" and "Restore Previous Session" become 2 row (previously showed as 1 row)

I'm using 1024x600 screen resolution (netbook).


Expected results:

Showed 1 line (1 row) as previously

I'm using 1024x600 screen resolution (netbook)
(Reporter)

Updated

2 years ago
OS: Unspecified → Windows 8
Hardware: Unspecified → x86

Updated

2 years ago
Component: Untriaged → General
So 43 on your resolution was showing one line, 44 shows 2 lines at the same resolution?

Actually the behavior you see (2 rows) is expected on small monitors, I'm not sure what changed from 43 to 44 to change the behavior at the same exact resolution.

The only changeset touching abouthome that could be related is
http://hg.mozilla.org/mozilla-central/rev/c0a884282954
that points to bug 962249.

Indeed it does

-  if (window.scrollMaxX) {
+  if (window.scrollMaxX != window.scrollMinX) {
     document.body.setAttribute("narrow", "true");

I don't know if the new behavior is more correct though, off-hand looks like the page has enough space to avoid going narrow. let's see what xidorn thinks.
Blocks: 962249
Status: UNCONFIRMED → NEW
Ever confirmed: true
Flags: needinfo?(quanxunzhen)
Keywords: regression
Ah, this is a dupe
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Flags: needinfo?(quanxunzhen)
Resolution: --- → DUPLICATE
Duplicate of bug: 1244221
(Reporter)

Comment 3

2 years ago
(In reply to Marco Bonardo [::mak] from comment #1)
> So 43 on your resolution was showing one line, 44 shows 2 lines at the same
> resolution?
> 
> Actually the behavior you see (2 rows) is expected on small monitors, I'm
> not sure what changed from 43 to 44 to change the behavior at the same exact
> resolution.
> 
> The only changeset touching abouthome that could be related is
> http://hg.mozilla.org/mozilla-central/rev/c0a884282954
> that points to bug 962249.
> 
> Indeed it does
> 
> -  if (window.scrollMaxX) {
> +  if (window.scrollMaxX != window.scrollMinX) {
>      document.body.setAttribute("narrow", "true");
> 
> I don't know if the new behavior is more correct though, off-hand looks like
> the page has enough space to avoid going narrow. let's see what xidorn
> thinks.

YES, before upgraded into FF 44.0 I'm using the same screen resolution AND it was not showed as 2 rows before.
(Reporter)

Updated

2 years ago
OS: Windows 8 → All
Hardware: x86 → All
You need to log in before you can comment on or make changes to this bug.