Site with Google's AdSense ads sometimes redirects back to previous page

RESOLVED WORKSFORME

Status

()

RESOLVED WORKSFORME
3 years ago
3 years ago

People

(Reporter: taetimo, Unassigned)

Tracking

44 Branch
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: dom-triaged)

(Reporter)

Description

3 years ago
User Agent: Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/48.0.2564.97 Safari/537.36

Steps to reproduce:

Visit the website at http://www.keltainenporssi.fi where Google AdSense ads were enabled and refreshed the site until the behavior occurred.


Actual results:

I was incorrectly redirected back to a previous site. This only started happening recently and does not appear to happen in other browsers. It happens occasionally, but often enough to be a problem.


Expected results:

Should have stayed on the same site.

Comment 1

3 years ago
It's bug 1244326 or bug 1244517
Depends on: 1244326, 1244517

Comment 2

3 years ago
Trying to reproduce this....


Reporter, did you investigate whether it is AdSense ads which are causing the session history traversal?
(Reporter)

Comment 3

3 years ago
While the AdSense ads are disabled (as they currently are for Firefox on this site), I have not been able to reproduce this issue. Which led me to believe that the issue must be related to the ads. However, I've also not been able to narrow it down to any specific ad.

Comment 4

3 years ago
I reported this to Google, but trying to reproduce and understand what is actually happening.

Comment 5

3 years ago
How does one enable AdSense ads for the site?

Comment 6

3 years ago
(ja ihan voit linkittää vaikka johonkin suomenkieliseen ohjeeseen miten laittaa adsense päälle. Pitääkö kenties olla kirjautuneena Keltaiseen Pörssiin?)

Updated

3 years ago
Flags: needinfo?(taetimo)
(Reporter)

Comment 8

3 years ago
Looking at the other issues I guess this can be considered a duplicate.

I've added an option for reproducing the behavior. Just like in the other issues (1244560, 1244517):
1. Open any website (e.g. about:home)
2. Enter this address in the address bar http://www.keltainenporssi.fi/#debug-adsense
3. Wait for the page to load (a few seconds)
4. If not redirected, refresh until it occurs (usually 3-5 times)

You can verify that the redirect does not happen when the #debug-adsense hash is omitted.
(Reporter)

Updated

3 years ago
Flags: needinfo?(taetimo)

Comment 9

3 years ago
So I've reported the issue to Google. As far as I see, this is an issue in their scripts.

Comment 10

3 years ago
Other site examples to reproduce the BUG...
http://www.infobel.com/es/argentina/rebot_silvana_marcela/santa_teresita/AR100589229/businessdetails.aspx
http://www.lanacion.com.ar
http://www.clarin.com
http://www.ambito.com
etc...
I confirmed that this new BUG is on lasts 43.x version and 44.0 of firefox for windows!
And if you use PRIVATE BROWSING or UBP (ad blocker) the ads dont load and then there is NO BUG!
It only happends with Google ADS!

Updated

3 years ago
Component: Untriaged → Document Navigation
Product: Firefox → Core

Comment 11

3 years ago
¡Hola Olli!

Confirming based on https://bugzilla.mozilla.org/show_bug.cgi?id=1245042#c9

¡Hola Timo!

Could you please check https://bugzilla.mozilla.org/show_bug.cgi?id=1245042#c1 and decide if this is in fact a duplicate of either of those?

¡Gracias!
Status: UNCONFIRMED → NEW
Ever confirmed: true
Flags: needinfo?(taetimo)
(Reporter)

Comment 12

3 years ago
Hello Alex

Yes, both bug 1244326 and bug 1244517 seem to be referencing the same problem.
Should I mark this one as a duplicate then?
Flags: needinfo?(taetimo)

Comment 13

3 years ago
¡Hola Olli!

What do we do with this bug?

Dupe it?

¡Gracias!
Flags: needinfo?(bugs)
I guess doesn't matter right now. I'm still waiting for feedback from Google. The issue got forwarded to the right team.
So let's wait couple of days before hassling with bug states.
Flags: needinfo?(bugs)
Whiteboard: dom-triaged
Is this still happening?
Flags: needinfo?(taetimo)
Looks like the reporter isn't active. Alex, can you still reproduce?
Flags: needinfo?(alex_mayorga)
(Reporter)

Comment 17

3 years ago
Sorry about the delay in answering.
No, this is not happening anymore. The issue disappeared a few days after reporting it.
I can only presume it was fixed by Google.
Flags: needinfo?(taetimo)
(In reply to Timo Tae from comment #17)
> Sorry about the delay in answering.

No problem! Buzilla said you hadn't been active in a while so I assumed you were otherwise occupied. Thanks for responding.

> No, this is not happening anymore. The issue disappeared a few days after
> reporting it.
> I can only presume it was fixed by Google.

\o/

Thanks for verifying.
Flags: needinfo?(alex_mayorga)
WORKSFORME because I don't know what we use for FIXEDBYTHIRDPARTY.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.