Closed Bug 1245048 Opened 4 years ago Closed 4 years ago

Unchecked call to GetPrototype in vm/SelfHosting.cpp

Categories

(Core :: JavaScript Engine, defect)

defect
Not set

Tracking

()

RESOLVED FIXED
mozilla47
Tracking Status
firefox47 --- fixed

People

(Reporter: bbouvier, Assigned: bbouvier)

References

(Blocks 1 open bug)

Details

(Keywords: coverity, Whiteboard: [CID 1351131])

Attachments

(1 file)

Found by Coverity.

It might be that we want JS_ALWAYS_TRUE here, or not at all, I don't know enough about the context, so letting this decision to you, till.
Attachment #8714719 - Flags: review?(till)
Comment on attachment 8714719 [details] [diff] [review]
checkgetprototype.patch

Review of attachment 8714719 [details] [diff] [review]:
-----------------------------------------------------------------

Huh, this is a genuine bug - there's no real reason why this GetPrototype call should always succeed. Thanks for the catch and fix.
Attachment #8714719 - Flags: review?(till) → review+
Thanks for the quick review!
Assignee: nobody → bbouvier
Status: NEW → ASSIGNED
https://hg.mozilla.org/mozilla-central/rev/113fc521664e
Status: ASSIGNED → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla47
Duplicate of this bug: 1245517
You need to log in before you can comment on or make changes to this bug.