canvas context2D antialiasing regression (drawImage V.44 - v.45 + generalized > v.46)

RESOLVED WORKSFORME

Status

()

--
major
RESOLVED WORKSFORME
3 years ago
2 years ago

People

(Reporter: tristan.fraipont, Unassigned)

Tracking

({regression})

45 Branch
Unspecified
Mac OS X
regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [gfx-noted])

Attachments

(4 attachments, 1 obsolete attachment)

(Reporter)

Description

3 years ago
Created attachment 8714754 [details]
JaggedBorder.html

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.9; rv:45.0) Gecko/20100101 Firefox/45.0
Build ID: 20160127070712

Steps to reproduce:

In v.44 to v.45, rotate the context by 45 degrees, then use the drawImage method.
In v.46 rotate the context by 45 degrees, and draw a line or a rect.

online fiddle : https://jsfiddle.net/ty1rnc4x/

[confirmed on mac, I didn't tested on other OS]


Actual results:

The drawn shape has jagged borders


Expected results:

The borders should be smoother.
(Reporter)

Updated

3 years ago
Severity: normal → major
Component: Untriaged → Canvas: 2D
OS: Unspecified → Mac OS X
Product: Firefox → Core
Can you find a regression window using mozregression?
Flags: needinfo?(tristan.fraipont)
Keywords: regression, regressionwindow-wanted
I haven't been able to reproduce a rendering difference on a 2013 MBP w/ OSX 10.11.
(Reporter)

Comment 3

3 years ago
Created attachment 8716746 [details]
10.10.3 FF38.tiff

Screenshot of the expected result as it is in FF38
Flags: needinfo?(tristan.fraipont)
(Reporter)

Comment 4

3 years ago
Created attachment 8716747 [details]
10.10.3 FF44.png

Screenshot of the bugged output in FF44
(Reporter)

Updated

3 years ago
Attachment #8716746 - Attachment mime type: image/png → image/tiff
(Reporter)

Comment 5

3 years ago
(In reply to Jeff Muizelaar [:jrmuizel] from comment #1)
> Can you find a regression window using mozregression?

Sorry, I spent the weekend trying to install mozregression-gui without success...


(In reply to Ryan VanderMeulen [:RyanVM] from comment #2)
> I haven't been able to reproduce a rendering difference on a 2013 MBP w/ OSX
> 10.11.

I am able to reproduce it on the same macbook pro Early 2011 (gc  Intel HD Graphics 3000 512 MB) on 10.10 and 10.11 so this is not OS version dependent.
(Reporter)

Updated

3 years ago
Attachment #8716746 - Attachment is obsolete: true
(Reporter)

Comment 6

3 years ago
Created attachment 8716748 [details]
10.10.3 FF38.png

Screenshot of the expected result in FF38
(In reply to Kaiido from comment #5)
> (In reply to Jeff Muizelaar [:jrmuizel] from comment #1)
> > Can you find a regression window using mozregression?
> 
> Sorry, I spent the weekend trying to install mozregression-gui without
> success...

What problem did you run into with mozregression-gui?
Flags: needinfo?(tristan.fraipont)
Created attachment 8745020 [details]
Screen Shot 2016-04-25 at 11.57.58 AM.png

The testcase looks the same to me comparing Chrome and Firefox 48.0a1.
Kaiido, can you please confirm that you still see this in the latest Firefox Nightly build?
Flags: needinfo?(tristan.fraipont)
Whiteboard: [gfx-noted]
(Reporter)

Comment 10

2 years ago
Indeed, it's fixed.
Now drawImage in nightly does produce the exact same pixels as fillRect in v.44 !
fillRect in Nightly does produce an other result but it's not jagged anymore.

For moz-regression, the error I have is "ERROR: No module named sip", I still can't use it, but it's not related with this bug report.

Ps: I don't know how to mark as "Fixed"
Flags: needinfo?(tristan.fraipont)
Thank you for checking. I'm closing this bug as WORKSFORME since I don't see a fix that we made directly to this issue. Please reopen the bug report if the issue returns.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Keywords: regressionwindow-wanted
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.