Crash when Fennec Nightly visits a page with Basic Authentication

VERIFIED DUPLICATE of bug 1243354

Status

()

Firefox for Android
Logins, Passwords and Form Fill
VERIFIED DUPLICATE of bug 1243354
2 years ago
2 years ago

People

(Reporter: r_kato, Assigned: ahunt)

Tracking

({regression})

47 Branch
All
Android
regression
Points:
---

Firefox Tracking Flags

(firefox46 unaffected, firefox47- fixed, fennec47+)

Details

(crash signature)

(Reporter)

Description

2 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; rv:47.0) Gecko/20100101 Firefox/47.0
Build ID: 20160201030241

Steps to reproduce:

Visit http://htaccess.cman.jp/sample_go/basic/


Actual results:

Fennec Nightly crashed.


Expected results:

Fennec should not crash, and a prompt for username and password should be popped up.
(Reporter)

Comment 1

2 years ago
Crash Report ID: bp-41bc994f-afdd-476f-aad7-c75652160202
Crash Signature: [@ java.lang.ClassCastException: android.support.design.widget.TextInputLayout cannot be cast to android.widget.EditText at org.mozilla.gecko.prompts.PromptInput$EditInput.getValue(PromptInput.java) ]
[Tracking Requested - why for this release]: Regession
Status: UNCONFIRMED → NEW
tracking-fennec: --- → ?
status-firefox46: --- → unaffected
status-firefox47: --- → affected
tracking-firefox47: --- → ?
Ever confirmed: true
Keywords: regression
OS: Unspecified → Android
Hardware: Unspecified → All
The first build with crashes on crash stats is 20160201030241 and with 5+ crashes a day it seems safe to assume that something landed on Jan 29 broke this.
Assignee: nobody → ahunt
tracking-fennec: ? → 47+
(Assignee)

Comment 4

2 years ago
This seems to be a duplicate of Bug 1243354 which is now fixed, I can't reproduce this on current nightly (47.0a1, 2016-02-04).
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1243354
verified
Status: RESOLVED → VERIFIED

Comment 6

2 years ago
No need to track this bug since it's a duplicate.
tracking-firefox47: ? → -
status-firefox47: affected → fixed
You need to log in before you can comment on or make changes to this bug.