{css1}not using list-style-type when list-style-image fails

VERIFIED FIXED in M10

Status

()

P2
major
VERIFIED FIXED
19 years ago
2 years ago

People

(Reporter: dbaron, Assigned: buster)

Tracking

({css1})

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

DESCRIPTION:  When a list-style-image doesn't load, you should use the usual
marker for the list-style-type.  This doesn't happen.

STEPS TO REPRODUCE:  Load attached test case.

ACTUAL RESULTS:  Only the first item has a circle marker.

EXPECTED RESULTS:  Both items should have a circle marker.

DOES NOT WORK CORRECTLY ON:
 * Linux, viewer, 1999-08-24-08-M10

ADDITIONAL INFORMATION:
  You should probably also use the marker while the image is loading.
Created attachment 1382 [details]
test case described in report
WORKS CORRECTLY IN:
 * Nav 4.6 Linux.
Summary: not using list-style-type when list-style-image fails → {css1}not using list-style-type when list-style-image fails
OS: Linux → All
Hardware: PC → All
ALSO DOES NOT WORK CORRECTLY IN:
 * Windows apprunner 1999-08-24-09-M10

Marking All/All.

ALSO DOES WORK CORRECTLY IN:
 * Windows IE 4.0

Updated

19 years ago
Assignee: troy → kipp

Updated

19 years ago
Severity: normal → major
Status: NEW → ASSIGNED
Priority: P3 → P2
Target Milestone: M10

Updated

19 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → FIXED

Comment 4

19 years ago
Fixed. The list-style-type is used when the image is loading, and if the load
fails.

Updated

19 years ago
Status: RESOLVED → VERIFIED

Comment 5

19 years ago
Fixed in the Sept 2nd build (1999090208).

Comment 6

19 years ago
*** Bug 10777 has been marked as a duplicate of this bug. ***
Keywords: css1
Migrating from {css1} to css1 keyword. The {css1}, {css2}, {css3} and {css-moz}
radars should now be considered deprecated in favour of keywords.
I am *really* sorry about the spam...
You need to log in before you can comment on or make changes to this bug.