Closed Bug 1245129 Opened 4 years ago Closed 4 years ago

Cannot drag page content from Firefox to other applications or browsers

Categories

(Core :: Widget: Win32, defect)

44 Branch
x86_64
Windows 7
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 1243507
Tracking Status
firefox44 --- wontfix
firefox45 - fixed
firefox46 + fixed
firefox47 + fixed

People

(Reporter: rdefusco, Unassigned)

References

Details

(Keywords: regression)

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:44.0) Gecko/20100101 Firefox/44.0
Build ID: 20160123151951

Steps to reproduce:

This issue started with Firefox 44 on Windows and was not an issue with the 43 branch or earlier. Affects every user that has upgraded to 44 but users still on 43 are not having issues.

Steps:

1. Go to a site like http://example.com/ and select some text, such as "This domain" from the first sentence on the site.
2. Now click and drag the selected text into another application such as Notepad, or the Google.com search text field in Internet Explorer and it will show the circle with the line through it cursor and not let you drop the selected text.

If you drag text in Firefox and drop it in text field in Firefox it works, it just doesn't work outside of Firefox.


Actual results:

The cursor shows the circle with the line through it indicating the text cannot be dropped.


Expected results:

The text should be to be dropped into the external application.
OS: Unspecified → Windows 7
Hardware: Unspecified → x86_64
It's a known bug, see 1243507.
Component: Untriaged → Widget: Win32
Depends on: 1243507
Product: Firefox → Core
Actually it isn't, but I confirmed the issue.
Status: UNCONFIRMED → NEW
No longer depends on: 1243507
Ever confirmed: true
I got the same regression range.
But I couldn't fix the issue with patches from bug 1243507...
(In reply to Loic from comment #3)
> I got the same regression range.

Is it really correct? I couldn't drag the text to Notepad even with Firefox 43.0.4.
Status: NEW → UNCONFIRMED
Ever confirmed: false
Flags: needinfo?(epinal99-bugzilla2)
(In reply to Masatoshi Kimura [:emk] from comment #5)
> (In reply to Loic from comment #3)
> > I got the same regression range.
> 
> Is it really correct? I couldn't drag the text to Notepad even with Firefox
> 43.0.4.

STR:
1) Start IE or Edge and open http://www.bing.com/
2) Select some random text from tab in Firefox
3) Drag and drop selected text in Bing search field

Result: operation not possible.
Flags: needinfo?(epinal99-bugzilla2)
See Also: → 1245488
OK, I could confirm it with the search field. "Notepad" confused me.
Status: UNCONFIRMED → NEW
Depends on: 1243507
Ever confirmed: true
Apparently Internet Explorer will not accept a drop that does not support CF_TEXT, even if it actually uses CF_UNICODETEXT or HTML Format to query the text. It's the Microsoft.
Tracking, sounds like a possible regression. Is this something we want to support? 
roc, what do you think (you are listed as module owner)
Flags: needinfo?(roc)
Bug 1243507 should have fixed this. Robert or Loic, could you verify it with the latest Nightly?
Flags: needinfo?(rdefusco)
Flags: needinfo?(epinal99-bugzilla2)
I verified it myself. Duping.
Status: NEW → RESOLVED
Closed: 4 years ago
No longer depends on: 1243507
Flags: needinfo?(roc)
Flags: needinfo?(rdefusco)
Flags: needinfo?(epinal99-bugzilla2)
Resolution: --- → DUPLICATE
Duplicate of bug: 1243507
You need to log in before you can comment on or make changes to this bug.