All users were logged out of Bugzilla on October 13th, 2018

Buttons for restoring session and starting new session are not rendered immediately since Fx44

RESOLVED WORKSFORME

Status

()

--
minor
RESOLVED WORKSFORME
3 years ago
3 years ago

People

(Reporter: ulrich.braunschweig, Unassigned)

Tracking

({regressionwindow-wanted, steps-wanted})

44 Branch
x86_64
All
regressionwindow-wanted, steps-wanted
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

3 years ago
User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:44.0) Gecko/20100101 Firefox/44.0
Build ID: 20160126223146

Steps to reproduce:

Any sitatuation that causes Firefox to offer session restoration (shutdown w/o closing FF, crash).

Firefox 44.0
Ubuntu 14.04.3
Unity 7.2.6



Actual results:

The page listing previously open windows and tabs is displayed, but the two buttons below, to start a new sessions and restore the old session, are initially not displayed. Only when moving the mouse pointer over the area or changing the window size do they appear. Restoration functions normally.

This behaviour started after update to 44.0.


Expected results:

Both buttons should be displayed immediately (as in all previous versions).
(Reporter)

Updated

3 years ago
Severity: normal → minor
OS: Unspecified → Linux
Hardware: Unspecified → x86_64

Updated

3 years ago
Component: Untriaged → Session Restore

Updated

3 years ago
Summary: Buttons for restoring session and starting new session are not rendered upon restart → Buttons for restoring session and starting new session are not rendered immediately since Fx44

Comment 1

3 years ago
Created attachment 8716315 [details]
session-restore-no-button.jpg

Yes, I observed that after testing some crash testcases. Both buttons appear only when the mouse is hovering over them.

Updated

3 years ago
Keywords: regressionwindow-wanted

Comment 2

3 years ago
Ulrich, are you able to reproduce the issue at 100%? 
I tried to crash FF following various ways (from the Process Manager, using this exe https://ftp.mozilla.org/pub/utilities/crashfirefox-intentionally/ etc) but each time, the session restore window displays the buttons.
Flags: needinfo?(ulrich.braunschweig)
(Reporter)

Comment 3

3 years ago
Yes. Out of 5x shutdown w/o closing FF and 3x killing FF from the Process Manager, the behaviour was as described in all cases.
Let me know if you need more information about my setup.
Flags: needinfo?(ulrich.braunschweig)

Comment 4

3 years ago
Yes, there is useful tool called Mozregression to find a regression range in Firefox.
See http://mozilla.github.io/mozregression/ for details (it's python-2.7 package).

But I don't know how to build an easy set-up to reproduce this issue with mozreg. The tool downloads a nightly build so that implies to copy the /firefox folder and test the issue with this copy instead of the build launched by mozreg (there is no restart feature).

Comment 5

3 years ago
(In reply to Loic from comment #4)
> Yes, there is useful tool called Mozregression to find a regression range in
> Firefox.
> See http://mozilla.github.io/mozregression/ for details (it's python-2.7
> package).
> 
> But I don't know how to build an easy set-up to reproduce this issue with
> mozreg. The tool downloads a nightly build so that implies to copy the
> /firefox folder and test the issue with this copy instead of the build
> launched by mozreg (there is no restart feature).

'Retry' action. --profile-persistence clone-first.
Keywords: steps-wanted
OS: Linux → All

Comment 6

3 years ago
Yes, good idea. Ulrich, here the steps to use Mozreg:

1) Create a custom profile and open a few random tabs (don't forget to select "Show my windows and tabs from last time" in about:preferences#general)
2) Run mozreg with the command:
mozregression --good=43 --profile=user/path_to_profile --profile-persistence=clone-first
3) For each build downloaded by mozreg, make it crash then type "retry" in the console to restart the build and make display the restore session tab.
4) Observe if the buttons are rendered or not, then type "good" or "bad".

After that, copy here the final pushlog.
Flags: needinfo?(ulrich.braunschweig)
Firefox: 44.0.2 Build ID: 20160210153822
User Agent  Mozilla/5.0 (X11; Linux x86_64; rv:44.0) Gecko/20100101 Firefox/44.0
Firefox: 47.0a1, Build ID: 20160222030212
User Agent  Mozilla/5.0 (X11; Linux x86_64; rv:47.0) Gecko/20100101 Firefox/47.0

Hi Ulrich,

I have tested this issue on latest Firefox (44.0.2) release, latest Nightly (47.0a1) build and I could not reproduce it. I have crashed Firefox over 20 times and after reopening it the session restore and the start new session buttons were displayed.

Can you please test this on the latest Firefox release (44.0.2) or latest Nightly (47.0a1, https://nightly.mozilla.org/) and tell me if this still reproduces for you ? When doing this please use a new fresh Firefox profile, maybe also in safe mode (https://support.mozilla.org/en-US/kb/troubleshoot-and-diagnose-firefox-problems). 

Thanks,
Cosmin.
(Reporter)

Comment 8

3 years ago
With the current build (44.0.2) the issue has been resolved. Buttons display as they should.
Sorry I didn't manage to triage it...
Flags: needinfo?(ulrich.braunschweig)
Hi Ulrich,

Thanks for the reply. Considering this I will mark this issue as Resolved - Worksforme. If you can still reproduce this, feel free to reopen it.

Thanks,
Cosmin.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.