remove toolkit/webapps/ code for desktop installation of Open Web Apps

RESOLVED DUPLICATE of bug 1238079

Status

()

Toolkit
General
RESOLVED DUPLICATE of bug 1238079
2 years ago
2 years ago

People

(Reporter: myk, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

2 years ago
Once we've disabled the mozApps API (bug 1238576) and the desktop/Android runtimes (bug 1238079, bug 1235869), we should remove the toolkit/webapps/ code that handles native installation of Open Web Apps on desktop/Android.
Depends on: 1246071
The code in toolkit/webapps/ only handles desktop installation. There is some Android- and some B2G-specific code, but it's just to check if an app is launchable and where its ZIP package is. I've filed bug 1246071 to get rid of this code.
Summary: remove toolkit/webapps/ code for desktop/Android installation of Open Web Apps → remove toolkit/webapps/ code for desktop installation of Open Web Apps
No longer depends on: 1235869
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1238079
You need to log in before you can comment on or make changes to this bug.