ux: remove hover/reveal effects from diff side by side display

RESOLVED FIXED

Status

RESOLVED FIXED
3 years ago
3 years ago

People

(Reporter: vlad, Assigned: glob)

Tracking

Details

Attachments

(1 attachment)

Viewing a diff has effects that reveal additional lines and buttons to show more lines and stuff when they are hovered over.  This effect is a) slow (perhaps by design, the animation rate is frustratingly painful); and b) annoying to use -- if I want to click on one of the "show more lines" buttons, I need to:

1 - move the mouse over the diff line
2 - wait some timeout period for the animation to start
3 - wait for the animation to finish
4 - move the mouse to the +20 or whichever button
5 - hope that I didn't overshoot or pause somewhere along the way, causing the animation to get interrupted/reset/whatever.

This animation also seems to be done via JS instead of CSS animations.

Just please get rid of it entirely.  Having the two brown bars on the top and bottom of every side-by-side chunk (maybe even condensed down to one bar) is a small price to pay for not having the jarring animations and pauses while trying to review code.
Product: Developer Services → MozReview
You are talking about in the "Reviews" (activity) view, right?  The diff view always has those brown bars.

I imagine the intention in Review Board is that reviewers will spend most of their time in the diff view, but viewing the comments there is annoying, so, yeah, displaying the context all the time in the Reviews view is probably the way to go.  In general I agree with glandium that the way the diffs and comments are presented should be more alike between the Reviews view and the Diff view.
Duplicate of this bug: 1249484
(Assignee)

Updated

3 years ago
Assignee: nobody → glob
Component: General → Review Board: User Interface
(Assignee)

Comment 3

3 years ago
Created attachment 8767589 [details]
reviewboard: remove hover/reveal effects when viewing diffs (bug 1245234)

The controls for expanding diff context are hidden with a slow javascript
animation to display.  Remove this pain point.

Function is commented out instead of removed to minimise merge conflicts.

Review commit: https://reviewboard.mozilla.org/r/62038/diff/#index_header
See other reviews: https://reviewboard.mozilla.org/r/62038/
Attachment #8767589 - Flags: review?(dwalsh)
Comment on attachment 8767589 [details]
reviewboard: remove hover/reveal effects when viewing diffs (bug 1245234)

https://reviewboard.mozilla.org/r/62038/#review60342

Love this!  Much more direct!
Attachment #8767589 - Flags: review?(dwalsh) → review+

Comment 5

3 years ago
Pushed by bjones@mozilla.com:
https://hg.mozilla.org/webtools/reviewboard/rev/48e917ce93a4
reviewboard: remove hover/reveal effects when viewing diffs r=davidwalsh
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.