Closed Bug 1245246 Opened 4 years ago Closed 4 years ago

crash in nsPrintEngine::FirePrintingErrorEvent

Categories

(Core :: Printing: Output, defect, major)

All
Windows
defect
Not set
major

Tracking

()

RESOLVED FIXED
mozilla47
Tracking Status
firefox45 --- fixed
firefox46 --- fixed
firefox47 --- fixed

People

(Reporter: bobowen, Assigned: bobowen)

Details

(Keywords: crash)

Crash Data

Attachments

(1 file)

This bug was filed from the Socorro interface and is 
report bp-67527034-9eee-429f-8e83-7e9932160202.
=============================================================

Looks like the mPrintEngine might be getting cleaned up too early in RemotePrintJobChild::RecvAbortPrint.
Not sure how this happens, I can only think that nsDocumentViewer is a bit too eager to call nsPrintEngine::Destroy.
Attachment #8715284 - Flags: review?(roc)
https://hg.mozilla.org/mozilla-central/rev/d1339eeb75cc
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla47
Comment on attachment 8715284 [details] [diff] [review]
Add null check for mDocViewerPrint in nsPrintEngine::FirePrintingErrorEvent

Approval Request Comment
[Feature/regressing bug #]:
Looks like this was introduced in bug 1199434 in Fx43.

[User impact if declined]:
This crash will continue to happen sometimes when a printing error occurs or the print is aborted.

[Describe test coverage new/current, TreeHerder]:
Manually reproduced the crash and tested fix.

[Risks and why]:
Low - simple null check.

[String/UUID change made/needed]:
None
Attachment #8715284 - Flags: approval-mozilla-beta?
Attachment #8715284 - Flags: approval-mozilla-aurora?
Comment on attachment 8715284 [details] [diff] [review]
Add null check for mDocViewerPrint in nsPrintEngine::FirePrintingErrorEvent

Fix a crash, taking it.
Attachment #8715284 - Flags: approval-mozilla-beta?
Attachment #8715284 - Flags: approval-mozilla-beta+
Attachment #8715284 - Flags: approval-mozilla-aurora?
Attachment #8715284 - Flags: approval-mozilla-aurora+
You need to log in before you can comment on or make changes to this bug.