Closed Bug 1245314 Opened 4 years ago Closed 4 years ago

Firefox Nightly 47.0a1 (2016-01-31) crashes in [@ mozilla::dom::HTMLFormElement::NotifySubmitObservers ]

Categories

(Core :: DOM: Core & HTML, defect, critical)

47 Branch
defect
Not set
critical

Tracking

()

VERIFIED FIXED
mozilla47
Tracking Status
firefox46 --- unaffected
firefox47 + verified

People

(Reporter: Virtual, Assigned: khuey)

References

Details

(Keywords: crash, nightly-community, regression)

Crash Data

Attachments

(1 file)

[Tracking Requested - why for this release]: Regression

STR:
1. Open some bug report on Bugzilla
2. Click "edit" in CC list
3. Paste some email address with CTRL+V keyboard shortcut
4. Click Enter keyboard button
is rare cases crash will happen

Crashlog report:
https://crash-stats.mozilla.com/report/index/428062fa-21a9-4509-85a4-6ccfa2160202
The crashes started with build (2016-01-31).

Suspected:
Bug #1241764 [Core:DOM]-Replace nsPIDOMWindow with nsPIDOMWindowInner/Outer
Blocks: 1241764
Summary: Firefox Nightly 47.0a1 crashes in [@ mozilla::dom::HTMLFormElement::NotifySubmitObservers ] → Firefox Nightly 47.0a1 (2016-01-31) crashes in [@ mozilla::dom::HTMLFormElement::NotifySubmitObservers ]
Assignee: nobody → khuey
Crash Signature: [@ mozilla::dom::HTMLFormElement::NotifySubmitObservers ]
Attached patch PatchSplinter Review
Attachment #8715381 - Flags: review?(amarchesini)
Attachment #8715381 - Flags: review?(amarchesini) → review+
I got a 100% reproduction method.
One of the repro's I done is the following crashreport: https://crash-stats.mozilla.com/report/index/dacebe3c-4621-4c84-afe1-3a55d2160203

Method:
1) Go to this page, https://code.google.com/p/mtasa-blue/downloads/list
2) then click Downloads tab in row of Project Home/Wiki/Issues (indicating where it is) and split moment, before it finishes loading this page redirect, you click Search button behind the text search box = crash

Assuming it's the same crash since at same location/adress
Above method adds a reliable reproduction, in contrast to Virtual_ManPL's one that was said to crash in rare cases. If you perform mine well (one time, very rapidly click after triggering loading the redirect) it means 100% crashrate.
https://hg.mozilla.org/mozilla-central/rev/0a5df57a56e4
Status: ASSIGNED → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla47
You need to log in before you can comment on or make changes to this bug.