mozprofile.addons WARNING | Could not install /fx-team/obj-fx-opt/_tests/testing/mochitest/extensions/mozscreenshots: [Errno 2] No such file or directory

RESOLVED DUPLICATE of bug 1371339

Status

()

Firefox
Build Config
RESOLVED DUPLICATE of bug 1371339
2 years ago
5 months ago

People

(Reporter: MattN, Unassigned)

Tracking

(Blocks: 1 bug)

Trunk
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox47 affected)

Details

Attachments

(1 attachment)

(Reporter)

Description

2 years ago
Created attachment 8715113 [details]
obj. directory layout

The following appears in the mochitest logs on every startup since bug 1169179 though the extension seems to "work" fine as it gets installed into the build:
> mozprofile.addons WARNING | Could not install /Users/matthew/repos/fx-team/obj-fx-opt/_tests/testing/mochitest/extensions/mozscreenshots: [Errno 2] No such file or directory: '/Users/matthew/repos/fx-team/obj-fx-opt/_tests/testing/mochitest/extensions/mozscreenshots/install.rdf'

I suspect the problem is the 2 chrome.manifest files and/or the "browser/" directory?

Mike, do you know what's going on and how to fix it?
Flags: needinfo?(mh+mozilla)
You know as much as I do: there is file missing. I guess it simply means the mozscreenshots addon is not in the test archive at all or in an unpacked form.
Flags: needinfo?(mh+mozilla)
(Reporter)

Comment 2

2 years ago
glandium, is it expected that the "browser" directory gets created though?

https://dxr.mozilla.org/mozilla-central/source/obj-x86_64-unknown-linux-gnu/_tests/testing/mochitest/extensions/mozscreenshots
Flags: needinfo?(mh+mozilla)
Considering it's under browser/, yes.
Flags: needinfo?(mh+mozilla)
Bisection points to this appears to be a regression from bug 1265202 [1]. Full details:

> 691 mozprofile.addons WARNING | Could not install /home/worker/workspace/build/tests/mochitest/extensions/mozscreenshots: [Errno 2] No such file or directory: '/home/worker/workspace/build/tests/mochitest/extensions/mozscreenshots/install.rdf'

This warning [2] shows up in the following test suites:

>     42 - [TC] Linux64 mochitest-chrome-1 c1
>     32 - [TC] Linux64 mochitest-chrome-3 c3
>     31 - [TC] Linux64 mochitest-clipboard cl
>     29 - [TC] Linux64 mochitest-clipboard-e10s cl
>     19 - [TC] Linux64 mochitest-chrome-2 c2
>     18 - [TC] Linux64 mochitest-browser-chrome-e10s-5 bc5
>     18 - [TC] Linux64 mochitest-browser-chrome-e10s-1 bc1
>     18 - [TC] Linux64 mochitest-browser-chrome-e10s-2 bc2
>     17 - [TC] Linux64 mochitest-browser-chrome-e10s-3 bc3
>     17 - [TC] Linux64 mochitest-browser-chrome-4 bc4
>     17 - [TC] Linux64 mochitest-plain-e10s-5 5
>     17 - [TC] Linux64 mochitest-browser-chrome-5 bc5
>     17 - [TC] Linux64 mochitest-6 6
>     16 - [TC] Linux64 mochitest-browser-chrome-6 bc6
>     16 - [TC] Linux64 mochitest-browser-chrome-e10s-4 bc4
>     15 - [TC] Linux64 mochitest-4 4
>     15 - [TC] Linux64 mochitest-plain-e10s-9 9
>     15 - [TC] Linux64 mochitest-10 10
>     14 - [TC] Linux64 mochitest-7 7
>     14 - [TC] Linux64 mochitest-8 8
>     14 - [TC] Linux64 mochitest-9 9
>     14 - [TC] Linux64 mochitest-3 3
>     14 - [TC] Linux64 mochitest-5 5
>     14 - [TC] Linux64 mochitest-browser-chrome-2 bc2
>     14 - [TC] Linux64 mochitest-plain-e10s-3 3
>     14 - [TC] Linux64 mochitest-plain-e10s-2 2
>     14 - [TC] Linux64 mochitest-1 1
>     13 - [TC] Linux64 mochitest-plain-e10s-4 4
>     13 - [TC] Linux64 mochitest-browser-chrome-1 bc1
>     13 - [TC] Linux64 mochitest-plain-e10s-10 10
>     13 - [TC] Linux64 mochitest-2 2
>     13 - [TC] Linux64 mochitest-plain-e10s-6 6
>     13 - [TC] Linux64 mochitest-plain-e10s-7 7
>     13 - [TC] Linux64 mochitest-plain-e10s-8 8
>     13 - [TC] Linux64 mochitest-plain-e10s-1 1
>     11 - [TC] Linux64 mochitest-browser-chrome-3 bc3
>      9 - [TC] Linux64 mochitest-media mda
>      9 - [TC] Linux64 mochitest-media-e10s mda
>      7 - [TC] Linux64 mochitest-gpu-e10s gpu
>      7 - [TC] Linux64 mochitest-gpu gpu
>      5 - [TC] Linux64 mochitest-gl gl
>      5 - [TC] Linux64 mochitest-devtools-chrome-8 dt8
>      5 - [TC] Linux64 mochitest-gl-e10s gl
>      5 - [TC] Linux64 mochitest-devtools-chrome-6 dt6
>      4 - [TC] Linux64 mochitest-devtools-chrome-2 dt2
>      4 - [TC] Linux64 mochitest-devtools-chrome-1 dt1
>      4 - [TC] Linux64 mochitest-devtools-chrome-3 dt3
>      4 - [TC] Linux64 mochitest-devtools-chrome-5 dt5
>      3 - [TC] Linux64 mochitest-devtools-chrome-7 dt7
>      3 - [TC] Linux64 mochitest-devtools-chrome-4 dt4
>      1 - [TC] Linux64 mochitest-a11y a11y
>      1 - [TC] Linux64 mochitest-devtools-chrome-9 dt9
>      1 - [TC] Linux64 mochitest-browser-chrome-e10s-6 bc6
>      1 - [TC] Linux64 mochitest-devtools-chrome-10 dt10
>      1 - [TC] Linux64 mochitest-browser-chrome-e10s-7 bc7
>      1 - [TC] Linux64 mochitest-browser-chrome-7 bc7
>      1 - [TC] Linux64 mochitest-jetpack JP

It shows up in 61 tests. A few of the most prevalent:

>    376 -        Shutdown
>    254 - [e10s] Shutdown
>      1 - [e10s] devtools/client/netmonitor/test/browser_net_copy_as_curl.js
>      1 - [e10s] toolkit/content/tests/browser/browser_save_resend_postdata.js
>      1 - [e10s] dom/tests/mochitest/notification/test_notification_resend.html
>      1 -        widget/tests/test_taskbar_progress.xul
>      1 - [e10s] toolkit/mozapps/extensions/test/browser/browser_bug593535.js
>      1 -        devtools/client/debugger/test/mochitest/browser_dbg_variables-view-popup-14.js
>      1 - [e10s] dom/imptests/html/webgl/test_compressedTexSubImage2D.html
>      1 -        dom/html/test/test_bug445004.html

[1] https://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=cb65ec85049efa44b18e2e8d06af26768c3bfb94&tochange=9a8ff2f4978493c3fd9982652a09ffcdf2333a75
[2] https://dxr.mozilla.org/mozilla-central/rev/88bebcaca249aeaca9197382e89d35b02be8292e/testing/mozbase/mozprofile/mozprofile/addons.py#343
Blocks: 765224
(Reporter)

Updated

5 months ago
See Also: → bug 1371339
(Reporter)

Comment 5

5 months ago
This is being fixed in bug 1371339
Status: NEW → RESOLVED
Last Resolved: 5 months ago
Resolution: --- → DUPLICATE
See Also: bug 1371339
Duplicate of bug: 1371339
(Reporter)

Updated

5 months ago
Duplicate of this bug: 1373783
You need to log in before you can comment on or make changes to this bug.