autoscroll in bookmarks folder menus is broken

VERIFIED DUPLICATE of bug 124485

Status

SeaMonkey
Bookmarks & History
P3
normal
VERIFIED DUPLICATE of bug 124485
16 years ago
12 years ago

People

(Reporter: Jeremy M. Dolan, Assigned: Ben Goodger (use ben at mozilla dot org for email))

Tracking

({regression})

Trunk
x86
All
regression

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
In the main bookmark menu (between go/tasks), you can't scroll down, as of very
recently. Scrolling up works.

You can scroll with the keyboard to get to lower bookmarks, but not with the
mouse on the arrow, by clicking or hovering.

Comment 1

16 years ago
Same on Win98, build 20020803.

Comment 2

16 years ago
win2k broken too 2-8-03... looks like scrolling GTK stuff causing problems?  
Keywords: nsbeta1, nsCatFood, regression

Comment 3

16 years ago
QA:

one more thing, I can only get the down scroller to go one folder before it stops.. 

also I checked bonsai, but nothing sticks in my view as a culprit, except
changes to XPCOM/glue stuff, a couple bugs that are about timers and hang/focus
problems and there are no JS console errors happening either in this build. 
took a guess at also bug 62199.

Comment 4

16 years ago
also see bug 124305, autoscrolling, timer stuff.

Comment 5

16 years ago
I also get this in personal toolbar menus, but I have one menu that will only
scroll down, and if you try to scroll up using cursor keys it automagically
scrolls back down to the bottom; I have also have a menu in personal toolbar the
has the inverse, you cannot scroll down and using cursor keys it forces itself
back to the top automagically.

Win2k SP2 build 2002020803

Comment 6

16 years ago
Is Bug #121871 a dup of this?

Comment 7

16 years ago
I dont think so.. its build 12-26.  This problem just started, and doesn't
appear to be the same.

Comment 8

16 years ago
the problem is the pull-down menu doesn't use show (or use) the depressed
downarrow line item.. this is allowed if you get a bookmark folder open that has
many bookmarks that go beyond view to the bottom of list.  If you try this
inside a long folder you will see the correct behavior is displayed (depressed
box, and arrow down produces the correct result) 

what is broke is Up version seems removed, broken, and root bookmark folder, and
long personal toolbar folders that show this.  

There one culprit that makes me think affected this.  A bug about scrolling for
clicking one new thread at a time in folder pane, so it created a half shown
thread msg, so a use can click down on it to bring it to view to traverse a
thread pane, as this maybe related.. 

maybe GTK widgets got horked up too.

Comment 9

16 years ago
this is real usability problem blocking me from doing real bug triage and testing.. 
Severity: normal → major
Keywords: mozilla1.0

Updated

16 years ago
OS: Linux → All
I do see this: if I hold the mouse on the last (bottom) folder in my list, or
first (top) folder, I can scroll with the arrow keys just fine thru my bookmarks..  

so Mouse events: autoscroll, or something is broken a connection or major widget
functional problem here.  need help with furthur investigation of cause of this bug.

Updated

16 years ago
Summary: downward scroll in bookmark menu is broken → autoscroll in bookmarks folder menus is broken

Comment 11

16 years ago
Nav Triage team:  marking nsbeta1+, reducing severity to normal, marking P3
Severity: major → normal
Keywords: nsbeta1 → nsbeta1+
Priority: -- → P3

Comment 12

16 years ago
*** Bug 124885 has been marked as a duplicate of this bug. ***

Comment 13

16 years ago
So, you're telling me that the fact that I can't use my mouse (on mouse over, or
on mouse click) to scroll through my Bookmark list isn't a major problem?

Gee I hope Netscape don't base a release on this codebase as they will be
inviting the same sort of comments they got with v6.0.

Comment 14

16 years ago
Um...it was marked nsbeta1+, which means a fix is wanted for the next Netscape
release. Check your facts before slamming others and embarrassing yourself.

Comment 15

16 years ago
I did check my facts. SEVERITY was changed from MAJOR to NORMAL, and PRIORITY
was set to P3, and it doesn't have a TARGET MILESTONE (apart from the hint in
KEYWORDS to v1.0. That all tells me that it is a low priority.
Blake, Peter,

I'd like to also suggest 0.9.9 and add it to block bug 122050 if we can squeeze
it in.
Keywords: mozilla0.9.9

Comment 17

16 years ago
Having read Bug 122050 "0.9.9 must rule" I'd suggest that having the mouse work
is critical for 0.9.9 to rule.

Comment 18

16 years ago
Any chance this is related to the nsScrollingView.cpp part of the fix for bug
45731?  I can't remember without the source in front of me if this is even used
by the scrolling menus, but it's around the same time.
Could this be a focus/event issue?

I've noticed 3 things that all worked in 2002-02-07-07 and are broken in
2002-02-07-22:

1)  This bug
2)  Clicking on search engine in the url bar dropdown (it no longer gets events)
    (bug 124740)
3)  Tabbing through <area> elements acts oddly (bug 124789)

#1 and #2 definitely seem related...
Taking a few guess here:

This bug 124299 (s/b for embedding) sticks out, but is for focus recursion
activation and bug 121944 (s/b for OS/2) for bookmarks popup for 1 click and not
two and bug 94242 for platform changes for windows hooks.

and bug 124024 seems to tie in timer stuff with clicking, for performance stuff.

Comment 22

16 years ago
*** Bug 124983 has been marked as a duplicate of this bug. ***

Comment 23

16 years ago
Same issue in Preferences->Navigator->Languages->Default Character Coding: the
drop down list cannot be scrolled with mouse, in both directions.
*** Bug 125054 has been marked as a duplicate of this bug. ***
No longer blocks: 124927
*** Bug 124927 has been marked as a duplicate of this bug. ***

Comment 27

16 years ago
The auto scroll works in build 20020205 which was the last version I was running 
before updating to the most recent nightly.

Comment 28

16 years ago
I don't know if it's relevant but I don't see the usual hover effect associated
with the up and down arrows either.

Comment 29

16 years ago
*** Bug 125203 has been marked as a duplicate of this bug. ***

Comment 30

16 years ago
*** Bug 125257 has been marked as a duplicate of this bug. ***

Comment 31

16 years ago
This bug also affects the context menu Move To/Copy To in the mail/news summary
pane.

Comment 32

16 years ago
*** Bug 126036 has been marked as a duplicate of this bug. ***

Comment 33

16 years ago
Using Win Me 4.90.300 the bookmark dropdown menu does not scroll using the
scroll arrow the the bottom. 

I also get and intermittent action with the scroll keys both up and down.
Sometimes it works and other times it justs scrolls and jumps to the top of the
list. This behavior the same for the up arrow and the down arrow.

Comment 34

16 years ago
I think this may be related to bug 125075, maybe even a dupe...

Comment 35

16 years ago
Dup of bug 124485?  That bug is marked as part of XP Toolkit, and putterman
suggests it affects all menus.

Comment 36

16 years ago
Yes, this is a dupe of bg 124485.

*** This bug has been marked as a duplicate of 124485 ***
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE

Comment 38

16 years ago
Whoops, I guess I should have done that!  Verifying.
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.