Closed Bug 1245436 Opened 9 years ago Closed 9 years ago

Font not recognized in current stable Firefox

Categories

(Core :: Graphics: Text, defect)

44 Branch
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 1244693
Tracking Status
firefox44 --- wontfix
firefox45 --- fixed
firefox46 --- fixed
firefox47 --- fixed

People

(Reporter: sonstiges, Unassigned)

Details

(Keywords: regression)

User Agent: Mozilla/5.0 (Windows NT 10.0; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/48.0.2564.97 Safari/537.36

Steps to reproduce:

Open http://webfonts.ffonts.net/Znikomit.font to display the Znikomit webfont


Actual results:

The Znikomit webfont should be displayed


Expected results:

Znikomit is not displayed. The fallback font is used. The correct font was displayed in the last version of Firefox
The Firefox User Agent is: Mozilla/5.0 (Windows NT 10.0; WOW64; rv:44.0) Gecko/20100101 Firefox/44.0
Sorry, actual and expected results are accidentally swapped. Of course the expected result is, that the Znikomit webfont should be displayed and the actual result is, that it it's not used and the fallback font is being displayed instead.
Regression range:
https://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=15104d2224f4d1c794994941e880d616cf9aa486&tochange=5baceaa01feee58e5dee795f9ef3bd2a596c8448
Status: UNCONFIRMED → NEW
Component: Untriaged → Graphics: Text
Ever confirmed: true
Flags: needinfo?(jfkthame)
Keywords: regression
Product: Firefox → Core
This is because the font is incorrect; its GPOS table violates the OpenType specification, and Firefox 44 is stricter about validating web fonts before allowing them to be used.

(Checking the web console, I see there are some other font errors on that site, too, although in some cases OTS may try to "fix up" the font and still allow it to be used.)

See bug 1244693.
Status: NEW → RESOLVED
Closed: 9 years ago
Flags: needinfo?(jfkthame)
Resolution: --- → DUPLICATE
flags removed because of duped
You need to log in before you can comment on or make changes to this bug.