Missing Pocket button from toolbar after moving it to the menu and restore

RESOLVED DUPLICATE of bug 1245447

Status

()

Firefox
Toolbars and Customization
RESOLVED DUPLICATE of bug 1245447
2 years ago
2 years ago

People

(Reporter: adalucinet, Unassigned)

Tracking

({regression})

Trunk
regression
Points:
---

Firefox Tracking Flags

(firefox44 unaffected, firefox45 unaffected, firefox46+ fixed, firefox47+ fixed)

Details

(Reporter)

Description

2 years ago
Affected versions: latest Aurora 46.0a2 and Nightly 47.0a1 (from 2016-02-02), e10s enabled/disabled
Affected platforms: Ubuntu 14.04 32-bit, Mac OS X 10.9.5 and Windows 7 64-bit

Steps to reproduce:
1. Launch Firefox with a clean profile.
2. Click on Menu panel (Hamburger button).
3. Select Customize.
4. Drag Pocket button to the Menu Panel.
5. Move at least 1 more button from the toolbar to the Menu panel.
6. Click 'Restore Defaults' button.
7. Repeat step 6.

Expected results: 'Restore defaults' button is not actionable.
Actual results: Pocket button no longer displayed in the toolbar, Menu Panel nor Additional Tools and Features. 

Additional notes:
1. Screen recording: https://goo.gl/hYyyqT
2. Via about:config page, 'extensions.pocket.enabled' pref is still set to true and 'browser.uiCustomization.state' points that the button is placed in nav-bar: 
'nav-bar': [
      'urlbar-container',
      'search-container',
      'bookmarks-menu-button',
      'pocket-button',
      'downloads-button',
      'home-button',
      'loop-button'
    ],
3. Unaffected version - 45 beta 2 (Build ID: 20160201143558) and 44.0RC build 3 (Build ID: 20160123151951).
4. Regression range:
Last good revision: 0c12d4229be0068eb1b9beb5064b800f12143f20
First bad revision: 3ba655f6bc67660a2dcfc4c2a5b3d0d17714f53d
Pushlog: https://hg.mozilla.org/integration/fx-team/pushloghtml?fromchange=0c12d4229be0068eb1b9beb5064b800f12143f20&tochange=3ba655f6bc67660a2dcfc4c2a5b3d0d17714f53d

Regressed by 3ba655f6bc67 Shane Caraveo — Bug 1215694 move pocket to a system addon
Tracking for 46+ since this is a recent regression.
tracking-firefox46: --- → +
tracking-firefox47: --- → +
Keywords: regression
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1245447
Marking fixed as this is now tracked in the duplicate bug.
status-firefox46: affected → fixed
status-firefox47: affected → fixed
You need to log in before you can comment on or make changes to this bug.