Closed Bug 1245450 Opened 4 years ago Closed 4 years ago

Image gallery shown in Fx 44 is not visible in Fx Developer Edition and Nightly

Categories

(Core :: Layout, defect)

46 Branch
defect
Not set

Tracking

()

RESOLVED FIXED
mozilla47
Tracking Status
firefox45 --- unaffected
firefox46 + fixed
firefox47 + fixed

People

(Reporter: nachtigall, Assigned: mattwoodrow)

References

Details

(Keywords: regression)

Attachments

(3 files)

User Agent: Mozilla/5.0 (Windows NT 6.3; WOW64; rv:46.0) Gecko/20100101 /
Build ID: 20160202004008

Steps to reproduce:

Go to https://www.flyingroasters.de/ Below "Lieblingsprodukte" there should be an image gallery consting of 5 images.


Actual results:

The images are not visible. Only on mouseover the images are flipped and replaced by other images.


Expected results:

Just as it is in Fx 43 or Fx 44: The images should be visible. It works in the stable Fx but not on current Developer Edition or Nightly. I just tried.
[Tracking Requested - why for this release]:
Status: UNCONFIRMED → NEW
Component: Untriaged → Layout
Ever confirmed: true
Keywords: regression
Product: Firefox → Core
Tracking since this is a regression
The above linked website just uses a common wordpress theme. The bug is also visible on these themes:
* http://themes.kadencethemes.com/virtue-premium-3/ (under "Products on Sale")
* http://themes.kadencethemes.com/pinnacle-premium/ (under "Featured Products")

Interestingly, when you switch to the last link from another tab, then the images a visible for a fraction of a second, then it the images become invisible again.
I wonder why nobody is assigned, so nobody taking care of this regression?

Virtue and Pinnacle themes are among the most popular wordpress themes with about 100K installations, so this will break a lot of sites.
Attached file reduced testcase
AR: nothing displayed
ER: should display "foo"
That's an awesome reduced test case, thanks Alice!
Assignee: nobody → matt.woodrow
https://hg.mozilla.org/mozilla-central/rev/596e6cf991c0
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla47
Matt should this uplift to 46?
Flags: needinfo?(matt.woodrow)
Comment on attachment 8719348 [details] [diff] [review]
Only setup AutoSaveRestorePerspectiveIndex for the descendants of the element with perspective

Approval Request Comment
[Feature/regressing bug #]: Bug 1168263
[User impact if declined]: Broken rendering for some 3d website
[Describe test coverage new/current, TreeHerder]: Manually tested, reftest added.
[Risks and why]: Low risk, isolated code change that only affects nested perspective.
[String/UUID change made/needed]: None
Flags: needinfo?(matt.woodrow)
Attachment #8719348 - Flags: approval-mozilla-aurora?
Comment on attachment 8719348 [details] [diff] [review]
Only setup AutoSaveRestorePerspectiveIndex for the descendants of the element with perspective

OK on m-c, adds a test, helps with preserve-3d regressions.
Please uplift to aurora.
Attachment #8719348 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
has problems to uplift to aurora

merging layout/generic/nsFrame.cpp
warning: conflicts while merging layout/generic/nsFrame.cpp! (edit, then use 'hg resolve --mark')
Flags: needinfo?(matt.woodrow)
You need to log in before you can comment on or make changes to this bug.