Drag of URL to "External Appliation" is missing windows clipboard flavor UniformResourceLocator

RESOLVED DUPLICATE of bug 1243507

Status

()

Firefox
Untriaged
RESOLVED DUPLICATE of bug 1243507
2 years ago
2 years ago

People

(Reporter: ole.sh, Unassigned)

Tracking

44 Branch
x86_64
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

2 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/48.0.2564.97 Safari/537.36

Steps to reproduce:

* Windows7, FF44 and FF Nightly 47.0a1 (2016-02-02)
* Drag an URL (e.g. a "normal" link) to an external Application


Actual results:

* The DataObject of the drag had only the following windows clipboard flavors:
* text/x-moz-url, FileGroupDescriptorW, FileContents, UniformResourceLocatorW, text/x-moz-url-data, text/x-moz-url-desc, text/uri-list, text/_moz_htmlcontext, text/_moz_htmlinfo, HTML Format, System.String, UnicodeText, Text, DragImageBits, DragContext



Expected results:

* Up to (including) FF 43 the DataObject of the drag had also the windows clipboard flavor UniformResourceLocator which is missing now
* This is causing a problem with external applications only looking for the UniformResourceLocator and not for UniformResourceLocatorW
(Reporter)

Updated

2 years ago
OS: Unspecified → Windows 7
Hardware: Unspecified → x86_64

Comment 1

2 years ago
Probably a dupe of bug 1245129.

Updated

2 years ago
See Also: → bug 1245129
Yes, the patch for bug 943294 will restore support for the "UniformResourceLocator" clipboard format.
(Reporter)

Comment 4

2 years ago
I tried the try-build https://archive.mozilla.org/pub/firefox/try-builds/VYV03354@nifty.ne.jp-6eb7767edf6ba9d042c9a94587b441db56afb270/try-win64/firefox-47.0a1.en-US.win64.installer.exe mentioned in bug 1243507. In this build the "UniformResourceLocator" clipboard format is back
Thanks, duping.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1243507
You need to log in before you can comment on or make changes to this bug.