Intermittent test_presentation_receiver_oop.html | Test timed out. and more presentation test failures.

RESOLVED DUPLICATE of bug 1263878

Status

()

Core
DOM: Device Interfaces
RESOLVED DUPLICATE of bug 1263878
2 years ago
2 years ago

People

(Reporter: aryx, Assigned: schien)

Tracking

({intermittent-failure})

Trunk
intermittent-failure
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

https://treeherder.mozilla.org/logviewer.html#?job_id=20994413&repo=mozilla-inbound

17:08:04     INFO -  383 INFO TEST-PASS | dom/presentation/tests/mochitest/test_presentation_receiver_oop.html | Message from iframe: OK navigator.presentation shouldn't be available in non-receiving OOP pages.
17:08:04     INFO -  384 INFO TEST-PASS | dom/presentation/tests/mochitest/test_presentation_receiver_oop.html | Messaging from iframe complete.
17:08:04     INFO -  385 INFO TEST-PASS | dom/presentation/tests/mochitest/test_presentation_receiver_oop.html | Message from iframe: OK Connection ID should be set: test-session-id
17:08:04     INFO -  386 INFO TEST-PASS | dom/presentation/tests/mochitest/test_presentation_receiver_oop.html | Message from iframe: OK Connection state at receiver side should be closed by default.
17:08:04     INFO -  387 INFO An offer is received.
17:08:04     INFO -  388 INFO TEST-PASS | dom/presentation/tests/mochitest/test_presentation_receiver_oop.html | A valid answer is sent.
17:08:04     INFO -  389 INFO TEST-UNEXPECTED-FAIL | dom/presentation/tests/mochitest/test_presentation_receiver_oop.html | Test timed out.
17:08:04     INFO -      reportError@SimpleTest/TestRunner.js:114:7
17:08:04     INFO -      TestRunner._checkForHangs@SimpleTest/TestRunner.js:134:7
17:08:04     INFO -      setTimeout handler*TestRunner._checkForHangs@SimpleTest/TestRunner.js:155:5
17:08:04     INFO -      setTimeout handler*TestRunner._checkForHangs@SimpleTest/TestRunner.js:155:5
17:08:04     INFO -      setTimeout handler*TestRunner._checkForHangs@SimpleTest/TestRunner.js:155:5
17:08:04     INFO -      setTimeout handler*TestRunner._checkForHangs@SimpleTest/TestRunner.js:155:5
17:08:04     INFO -      setTimeout handler*TestRunner._checkForHangs@SimpleTest/TestRunner.js:155:5
17:08:04     INFO -      setTimeout handler*TestRunner._checkForHangs@SimpleTest/TestRunner.js:155:5
17:08:04     INFO -      setTimeout handler*TestRunner._checkForHangs@SimpleTest/TestRunner.js:155:5
17:08:04     INFO -      setTimeout handler*TestRunner._checkForHangs@SimpleTest/TestRunner.js:155:5
17:08:04     INFO -      setTimeout handler*TestRunner._checkForHangs@SimpleTest/TestRunner.js:155:5
17:08:04     INFO -      setTimeout handler*TestRunner._checkForHangs@SimpleTest/TestRunner.js:155:5
17:08:04     INFO -      setTimeout handler*TestRunner._checkForHangs@SimpleTest/TestRunner.js:155:5
17:08:04     INFO -      TestRunner.runTests@SimpleTest/TestRunner.js:366:5
17:08:04     INFO -      RunSet.runtests@SimpleTest/setup.js:188:3
17:08:04     INFO -      RunSet.runall@SimpleTest/setup.js:167:5
17:08:04     INFO -      hookupTests@SimpleTest/setup.js:260:5
17:08:04     INFO -  parseTestManifest@http://mochi.test:8888/manifestLibrary.js:36:5
17:08:04     INFO -  getTestManifest/req.onload@http://mochi.test:8888/manifestLibrary.js:49:11
17:08:04     INFO -  EventHandlerNonNull*getTestManifest@http://mochi.test:8888/manifestLibrary.js:45:3
17:08:04     INFO -      hookup@SimpleTest/setup.js:240:5
17:08:04     INFO -  EventHandlerNonNull*@http://mochi.test:8888/tests?autorun=1&closeWhenDone=1&consoleLevel=INFO&manifestFile=tests.json&dumpOutputDirectory=%2Ftmp:11:1
17:08:04     INFO -  MEMORY STAT | vsize 1025MB | residentFast 220MB | heapAllocated 69MB
17:08:04     INFO -  390 INFO TEST-OK | dom/presentation/tests/mochitest/test_presentation_receiver_oop.html | took 323924ms
not sure if it related to bug 1245031. need further investigation.

Comment 2

2 years ago
6 automation job failures were associated with this bug in the last 7 days.

Repository breakdown:
* mozilla-inbound: 4
* mozilla-central: 1
* fx-team: 1

Platform breakdown:
* linux64: 6

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1245560&startday=2016-02-01&endday=2016-02-07&tree=all

Comment 3

2 years ago
18 automation job failures were associated with this bug in the last 7 days.

Repository breakdown:
* mozilla-inbound: 14
* fx-team: 3
* mozilla-central: 1

Platform breakdown:
* linux64: 17
* windows7-32: 1

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1245560&startday=2016-02-08&endday=2016-02-14&tree=all

Comment 4

2 years ago
18 automation job failures were associated with this bug yesterday.

Repository breakdown:
* mozilla-inbound: 15
* fx-team: 3

Platform breakdown:
* linux32: 10
* linux64: 8

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1245560&startday=2016-02-16&endday=2016-02-16&tree=all

Comment 5

2 years ago
60 automation job failures were associated with this bug in the last 7 days.

Repository breakdown:
* mozilla-inbound: 32
* fx-team: 19
* try: 7
* mozilla-central: 2

Platform breakdown:
* linux32: 31
* linux64: 29

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1245560&startday=2016-02-22&endday=2016-02-28&tree=all
(In reply to Shih-Chiang Chien [:schien] (UTC+8) (use ni? plz) from comment #1)
> not sure if it related to bug 1245031. need further investigation.

Doesn't appear to have helped. I've been trying to bisect this down a bit as well, and I've got it down to a merge at this point: https://treeherder.mozilla.org/#/jobs?repo=mozilla-inbound&revision=8a6976312049

Comment 7

2 years ago
38 automation job failures were associated with this bug yesterday.

Repository breakdown:
* mozilla-inbound: 21
* fx-team: 17

Platform breakdown:
* linux64: 38

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1245560&startday=2016-02-29&endday=2016-02-29&tree=all
(In reply to Ryan VanderMeulen [:RyanVM] from comment #6)
> (In reply to Shih-Chiang Chien [:schien] (UTC+8) (use ni? plz) from comment
> #1)
> > not sure if it related to bug 1245031. need further investigation.
> 
> Doesn't appear to have helped. I've been trying to bisect this down a bit as
> well, and I've got it down to a merge at this point:
> https://treeherder.mozilla.org/#/jobs?repo=mozilla-
> inbound&revision=8a6976312049

Doesn't see any obvious bug that directed related to this intermittent failure. Assign myself to investigate it.
Assignee: nobody → schien
Yeah, that proved to be a waste of effort. I was able to reproduce it even further back, but at a much lower frequency. I gave up looking for a smoking gun change because I'm not sure one exists or if it's worth the energy to find at this point.
(In reply to Ryan VanderMeulen [:RyanVM] from comment #9)
> Yeah, that proved to be a waste of effort. I was able to reproduce it even
> further back, but at a much lower frequency. I gave up looking for a smoking
> gun change because I'm not sure one exists or if it's worth the energy to
> find at this point.

That's ok. Maybe there is a timing issue in Presentation API code and I plan to use rr and chaos mode to figure out the root cause.

Comment 11

2 years ago
18 automation job failures were associated with this bug yesterday.

Repository breakdown:
* mozilla-inbound: 11
* fx-team: 5
* mozilla-central: 2

Platform breakdown:
* linux64: 14
* linux32: 4

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1245560&startday=2016-03-01&endday=2016-03-01&tree=all

Comment 12

2 years ago
81 automation job failures were associated with this bug in the last 7 days.

Repository breakdown:
* mozilla-inbound: 48
* fx-team: 27
* mozilla-central: 4
* try: 2

Platform breakdown:
* linux64: 67
* linux32: 14

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1245560&startday=2016-02-29&endday=2016-03-06&tree=all
From the log it looks like the state of PresentationConnection is already 'connected' while executing [1]. Therefore, test is timeout because there is no statechange event fired.

Double checking spec and code to figure out what should be fixed.

[1] https://dxr.mozilla.org/mozilla-central/source/dom/presentation/tests/mochitest/file_presentation_receiver_oop.html#79
There are other intermittent timeout under dom/presentation and might have the same root cause.

test_presentation_sender_disconnect.html
test_presentation_sender.html
test_presentation_sender_default_request.html

All the timeout happened while waiting for device availability change and all happened after the test_presentation_receiver_oop.html timeout.

Pushing a try to figure out if my patch works: https://treeherder.mozilla.org/#/jobs?repo=try&revision=3f1dca5a782a

Comment 15

2 years ago
15 automation job failures were associated with this bug yesterday.

Repository breakdown:
* mozilla-inbound: 13
* mozilla-central: 1
* fx-team: 1

Platform breakdown:
* linux64: 10
* linux32: 5

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1245560&startday=2016-03-11&endday=2016-03-11&tree=all

Comment 16

2 years ago
55 automation job failures were associated with this bug in the last 7 days.

Repository breakdown:
* mozilla-inbound: 42
* fx-team: 7
* try: 3
* mozilla-aurora: 2
* mozilla-central: 1

Platform breakdown:
* linux64: 37
* linux32: 18

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1245560&startday=2016-03-07&endday=2016-03-13&tree=all

Comment 17

2 years ago
22 automation job failures were associated with this bug in the last 7 days.

Repository breakdown:
* mozilla-inbound: 8
* mozilla-aurora: 6
* fx-team: 5
* mozilla-central: 2
* try: 1

Platform breakdown:
* linux64: 21
* linux32: 1

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1245560&startday=2016-03-14&endday=2016-03-20&tree=all
Teardown procedure is not triggered after test_presentation_receiver_oop.html timeout and that's the root cause of the following test timeout. Fix test_presentation_receiver_oop.html timeout is the key to this intermittent failure.

Comment 19

2 years ago
28 automation job failures were associated with this bug in the last 7 days.

Repository breakdown:
* mozilla-inbound: 14
* mozilla-aurora: 10
* fx-team: 3
* mozilla-central: 1

Platform breakdown:
* linux64: 24
* linux32: 4

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1245560&startday=2016-03-21&endday=2016-03-27&tree=all

Comment 20

2 years ago
20 automation job failures were associated with this bug in the last 7 days.

Repository breakdown:
* mozilla-inbound: 10
* fx-team: 6
* mozilla-central: 2
* mozilla-aurora: 2

Platform breakdown:
* linux64: 18
* linux32: 2

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1245560&startday=2016-03-28&endday=2016-04-03&tree=all

Comment 21

2 years ago
6 automation job failures were associated with this bug in the last 7 days.

Repository breakdown:
* mozilla-aurora: 3
* mozilla-inbound: 1
* mozilla-central: 1
* fx-team: 1

Platform breakdown:
* linux64: 5
* linux32: 1

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1245560&startday=2016-04-11&endday=2016-04-17&tree=all

Comment 22

2 years ago
9 automation job failures were associated with this bug in the last 7 days.

Repository breakdown:
* mozilla-aurora: 8
* try: 1

Platform breakdown:
* linux32: 6
* linux64: 3

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1245560&startday=2016-04-18&endday=2016-04-24&tree=all
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1263878
status-firefox47: affected → ---
You need to log in before you can comment on or make changes to this bug.