crash in npswf32.dll causing Exception_Access_Violation_Read and Full System Hangs with Flash Beta 21.0.0.130

RESOLVED WORKSFORME

Status

()

Core
Plug-ins
--
critical
RESOLVED WORKSFORME
2 years ago
11 months ago

People

(Reporter: Andrew Lynn, Unassigned)

Tracking

({crash, flashplayer, hang})

45 Branch
x86
Windows
crash, flashplayer, hang
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

2 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:44.0) Gecko/20100101 Firefox/44.0
Build ID: 20160123151951

Steps to reproduce:

Install Flash Beta 21.0.0.130
Install Firefox Beta 45.0b1

1 - Go to http://www.netromedia.com/video/video-streaming-examples/
2 - Scroll down until you notice "View Stream" Buttons in red
3 - Go through entire list of examples.
4 - Observe BUG / ISSUES

NOTE: IF user would disable "enable hardware acceleration" in the Firefox options > advanced menu this issue does not happen.

Note: This does not happen with other flash versions (like v20) and Firefox v45 B1.
Note: This does not happen with Flash Beta 21.0.0.130 and current Firefox 44 release.





Actual results:

Each example does not work.

Usually I am shown a flash crash message.

Firefox 45.0b2 = Does not crash but still non-functional players. UI rendering is broken. Unusable overall. Some examples just produce a white box and no flash player is loaded.


Expected results:

All Examples should work
(Reporter)

Updated

2 years ago
Keywords: crash, flashplayer
(Reporter)

Updated

2 years ago
Severity: normal → blocker
Keywords: hang
OS: Unspecified → Windows
Priority: -- → P1
Hardware: Unspecified → x86

Updated

2 years ago
Severity: blocker → critical
Priority: P1 → --

Updated

2 years ago
Component: Untriaged → Plug-ins
Product: Firefox → Core
What about latest Beta?
Flags: needinfo?(alynn)
(Reporter)

Comment 2

2 years ago
I had QA retest using Flash Beta 21.0.0.236. 

QA was still able produce the issues described above.
Flags: needinfo?(alynn)

Comment 3

11 months ago
Stefan, can you do some targeted testing of this? It's likely to be specific to certain graphics configurations, so you may need to get hardware details from Andrew if he's still available to help.
Flags: needinfo?(stefan.georgiev)
(Reporter)

Comment 4

11 months ago
Ben + Stefan,

I have not seen this issue with latest builds of Flash Beta.

This issue was originally created ~10 months ago and I believe the issues may have resolved itself.
Feel free to close this issue if your team is just cleaning up a 10+ month old backlog.

System details: Dell T3500 | Intel Xeon W3520 ~2.8GHz | 4GB RAM | ATI FirePro 2260

Updated

11 months ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 months ago
Resolution: --- → WORKSFORME

Comment 5

11 months ago
Taking my name off the cc, since this issue has been resolved.
Flags: needinfo?(stefan.georgiev)
You need to log in before you can comment on or make changes to this bug.