after upgrade to 44 youtube only shows 360p videos (Linux)

RESOLVED DUPLICATE of bug 1244900

Status

()

Core
Audio/Video: Playback
RESOLVED DUPLICATE of bug 1244900
2 years ago
2 years ago

People

(Reporter: illumilor.e, Unassigned)

Tracking

44 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

2 years ago
User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:44.0) Gecko/20100101 Firefox/44.0
Build ID: 2016012300

Steps to reproduce:

After upgrading to 44, now youtube will only show 360p videos and https://www.youtube.com/html5 shows h.264 as unsupported by firefox.

Updated

2 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1244900
(Reporter)

Comment 2

2 years ago
That bug says it is for xp only
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---

Updated

2 years ago
Component: Untriaged → Audio/Video: Playback
Product: Firefox → Core

Updated

2 years ago
Summary: after upgrade to 44 youtube only shows 360p videos → after upgrade to 44 youtube only shows 360p videos (Linux)

Comment 3

2 years ago
See https://bugzilla.mozilla.org/show_bug.cgi?id=1244900#c10
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1244900
(Reporter)

Comment 4

2 years ago
That bug says it is for xp only
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---
(In reply to illumilor.e from comment #4)
> That bug says it is for xp only

this is the same problem here.
You need a h264 decoder, if you haven't installed one then youtube will use webm vp8 or vp9

Go into youtube.com/html5
what does it display there? I assume h264 won't be active.

Unfortunately, not all youtube videos are available with vp9. So if you don't have h264, you will get the vp8 codec, and all YouTube videos using VP8 will be at 360p.

There's nothing we can do here: it's a YouTube issue.

Now if youtube.com/html5 shows h264 as being available, then you're right it would be a different problem. If it's not, this issue is really a dupe of 1244900
(Reporter)

Comment 6

2 years ago
Is there a firefox diagnostic telling you what decoders it has/ what it is using/ and where it is searching for them, because I have system h264 decoders installed.
what does youtube.com/html5 show ?

please provide the output of about:support here, maybe you've disabled ffmpeg in a pref.

What gstreamer or ffmpeg packages do you have installed?
(Reporter)

Comment 8

2 years ago
It shows 264 red, but mse+264 as blue.Application Basics
------------------

Name: Firefox
Version: 44.0
Build ID: 2016012300
User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:44.0) Gecko/20100101 Firefox/44.0
Multiprocess Windows: 0/1 (default: false)
Safe Mode: false

Crash Reports for the Last 3 Days
---------------------------------

All Crash Reports

Extensions
----------

Name: Greasemonkey
Version: 3.6
Enabled: true
ID: {e4a8a97b-f2ed-450b-b12d-ee082ba24781}

Name: Self-Destructing Cookies
Version: 0.4.9
Enabled: true
ID: jid0-9XfBwUWnvPx4wWsfBWMCm4Jj69E@jetpack

Name: Tab Mix Plus
Version: 0.4.2.0
Enabled: true
ID: {dc572301-7619-498c-a57d-39143191b318}

Name: uBlock Origin
Version: 1.5.5
Enabled: true
ID: uBlock0@raymondhill.net

Name: YouTube Plus
Version: 1.0.7
Enabled: false
ID: particle@particlecore.github.io

Name: Magic Actions for YouTube™
Version: 6.8.8.8
Enabled: false
ID: jid0-UVAeBCfd34Kk5usS8A1CBiobvM8@jetpack

Name: YouTube Center Developer Build
Version: 537
Enabled: false
ID: jid1-cwbvBTE216jjpg@jetpack

Name: YouTube High Definition
Version: 44.1
Enabled: false
ID: {7b1bf0b6-a1b9-42b0-b75d-252036438bdc}

Name: YouTube™ Enhancer Plus
Version: 4.0.8
Enabled: false
ID: firefoxaddon@youtubeenhancer.com

Graphics
--------

Adapter Description: NVIDIA Corporation -- GeForce GTX 750 Ti/PCIe/SSE2
Asynchronous Pan/Zoom: none
Device ID: GeForce GTX 750 Ti/PCIe/SSE2
Driver Version: 4.5.0 NVIDIA 361.18
GPU Accelerated Windows: 0/1 Basic (OMTC)
Supports Hardware H264 Decoding: No;
Vendor ID: NVIDIA Corporation
WebGL Renderer: NVIDIA Corporation -- GeForce GTX 750 Ti/PCIe/SSE2
windowLayerManagerRemote: true
AzureCanvasBackend: cairo
AzureContentBackend: cairo
AzureFallbackCanvasBackend: none
AzureSkiaAccelerated: 0
CairoUseXRender: 1

Important Modified Preferences
------------------------------

accessibility.typeaheadfind.flashBar: 0
browser.cache.disk.capacity: 358400000000
browser.cache.disk.filesystem_reported: 1
browser.cache.disk.smart_size.first_run: false
browser.cache.disk.smart_size.use_old_max: false
browser.cache.frecency_experiment: 2
browser.display.use_document_fonts: 0
browser.download.folderList: 2
browser.download.importedFromSqlite: true
browser.places.importBookmarksHTML: false
browser.places.smartBookmarksVersion: 7
browser.sessionstore.max_tabs_undo: 50
browser.sessionstore.restore_on_demand: false
browser.sessionstore.upgradeBackup.latestBuildID: 2016012300
browser.startup.homepage_override.buildID: 2016012300
browser.startup.homepage_override.mstone: 44.0
browser.tabs.tabMinWidth: 90
browser.tabs.warnOnOpen: false
browser.urlbar.userMadeSearchSuggestionsChoice: true
dom.apps.reset-permissions: true
dom.mozApps.used: true
extensions.lastAppVersion: 44.0
font.internaluseonly.changed: true
font.name.sans-serif.x-western: Droid Sans
gfx.crash-guard.glcontext.appVersion: 44.0
gfx.crash-guard.glcontext.deviceID: GeForce GTX 750 Ti/PCIe/SSE2
gfx.crash-guard.glcontext.driverVersion: 4.5.0 NVIDIA 361.18
gfx.crash-guard.status.glcontext: 2
media.fragmented-mp4.ffmpeg.enabled: true
media.gmp-gmpopenh264.abi: x86_64-gcc3
media.gmp-gmpopenh264.lastUpdate: 1451551027
media.gmp-gmpopenh264.version: 1.5.3
media.gmp-manager.buildID: 2016012300
media.gmp-manager.lastCheck: 1454541453
media.webrtc.debug.aec_log_dir: /tmp
media.webrtc.debug.log_file: /tmp/WebRTC.log
media.youtube-ua.override.to: 43
mousewheel.default.delta_multiplier_y: 400
network.cookie.prefsMigrated: true
network.http.speculative-parallel-limit: 0
network.predictor.cleaned-up: true
network.prefetch-next: false
places.database.lastMaintenance: 1453950234
places.history.expiration.transient_current_max_pages: 104858
plugin.disable_full_page_plugin_for_types: application/pdf
plugin.importedState: true
print.print_bgcolor: false
print.print_bgimages: false
print.print_duplex: 0
print.print_evenpages: true
print.print_in_color: true
print.print_margin_bottom: 0.5
print.print_margin_left: 0.5
print.print_margin_right: 0.5
print.print_margin_top: 0.5
print.print_oddpages: true
print.print_orientation: 0
print.print_page_delay: 50
print.print_paper_data: 0
print.print_paper_height: 11.00
print.print_paper_name: na_letter
print.print_paper_size_type: 1
print.print_paper_size_unit: 0
print.print_paper_width: 8.50
print.print_resolution: 600
print.print_scaling: 1.00
print.print_shrink_to_fit: true
print.print_to_file: false
print.print_unwriteable_margin_bottom: 56
print.print_unwriteable_margin_left: 25
print.print_unwriteable_margin_right: 25
print.print_unwriteable_margin_top: 25
privacy.donottrackheader.enabled: true
privacy.sanitize.migrateClearSavedPwdsOnExit: true
privacy.sanitize.migrateFx3Prefs: true
storage.vacuum.last.index: 1
storage.vacuum.last.places.sqlite: 1452821490

Important Locked Preferences
----------------------------

JavaScript
----------

Incremental GC: true

Accessibility
-------------

Activated: false
Prevent Accessibility: 0

Library Versions
----------------

NSPR
Expected minimum version: 4.11
Version in use: 4.11

NSS
Expected minimum version: 3.21 Basic ECC
Version in use: 3.21 Basic ECC

NSSSMIME
Expected minimum version: 3.21 Basic ECC
Version in use: 3.21 Basic ECC

NSSSSL
Expected minimum version: 3.21 Basic ECC
Version in use: 3.21 Basic ECC

NSSUTIL
Expected minimum version: 3.21
Version in use: 3.21

Experimental Features
---------------------

Sandbox
-------

Seccomp-BPF (System Call Filtering): true
Seccomp Thread Synchronization: true
User Namespaces: true
Media Plugin Sandboxing: true
(In reply to illumilor.e from comment #8)
> It shows 264 red, but mse+264 as blue.Application Basics

Now that is really surprising, as it's really technically an impossibility :)
To get mse+h264, you must have basic h264 available.

have you installed FFmpeg's libavcodec ? what distribution of linux are you using?

ohhh.. are you using OpenSuse by any chance ?
They ship with a very bizarre FFmpeg configuration, it has h264 support but not AAC.

So your problem won't be that you don't have h264 decoding, but that you don't have AAC audio.
This is the only way you could have mse+h264 blue, but h264 itself red.
(Reporter)

Comment 10

2 years ago
hhh.. are you using OpenSuse by any chance ?

Yes. I thought I was using ffmpeg from a different source but I guess it got changed at some point.

Is there a way to get firefox to tell you what codecs it can run? 
Like how youtube tells you about h.264 but more specific.
about:support doesn't say any codecs specifically.
we don't have such page no. We only provide information about h264 because under most circumstances, where you have h264 you also have AAC.

I've only seen the problem with OpenSuse ; because their configuration of their ffmpeg package is "abnormal".

I believe that their intention was to disable all patent encumbered codecs (h264, aac, mp3 in particular).
But they enabled h264 for vdpau and vaapi ; unknown to them that having those two on will enable the h264 decoder.
So in the end, their libavcodec has h264, but not AAC nor MP3.

To watch those particular YouTube videos, you need h264 *and* AAC. Otherwise you're stuck to webm/vp8 at 360p
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1244900
(In reply to Jean-Yves Avenard [:jya] from comment #11)
> To watch those particular YouTube videos, you need h264 *and* AAC. Otherwise
> you're stuck to webm/vp8 at 360p

There is an add-on to force YouTube to use Flash but then you get Flash for everything.
You need to log in before you can comment on or make changes to this bug.