Closed Bug 12458 Opened 20 years ago Closed 20 years ago

Apprunner asserts on startup

Categories

(Core :: XUL, defect, P3)

x86
Windows NT
defect

Tracking

()

VERIFIED DUPLICATE of bug 11474

People

(Reporter: jband_mozilla, Assigned: trudelle)

Details

[choosing XUL component at randon :)]

A fresh pull/build this morning asserts for me on NT at

nsBoxFrame::FlowChildAt

assertion:

NS_ASSERTION(NS_FRAME_IS_COMPLETE(aStatus), "bad status");


I notice that the alt-tab popup window has like twenty icons for apprunner.
What's that about?

NTDLL! 77f76274()
nsDebug::Assertion(const char * 0x018a6f94, const char * 0x018a6f74, const char
* 0x018a6f3c, int 0x0000035f) line 176 + 13 bytes
nsBoxFrame::FlowChildAt(nsIFrame * 0x028bbd30, nsIPresContext & {...},
nsHTMLReflowMetrics & {...}, const nsHTMLReflowState & {...}, unsigned int &
0x000000ff, nsCalculatedBoxInfo & {...}, int & 0x0173ea56, nsString & {...})
line 863 + 38 bytes
nsBoxFrame::GetChildBoxInfo(nsIPresContext & {...}, const nsHTMLReflowState &
{...}, nsIFrame * 0x028bbd30, nsCalculatedBoxInfo & {...}) line 227
nsBoxFrame::GetBoxInfo(nsBoxFrame * const 0x028df588, nsIPresContext & {...},
const nsHTMLReflowState & {...}, nsBoxInfo & {...}) line 1260 + 44 bytes
nsBoxFrame::Reflow(nsBoxFrame * const 0x028df54c, nsIPresContext & {...},
nsHTMLReflowMetrics & {...}, const nsHTMLReflowState & {...}, unsigned int &
0x00000000) line 323
nsContainerFrame::ReflowChild(nsIFrame * 0x028df548, nsIPresContext & {...},
nsHTMLReflowMetrics & {...}, const nsHTMLReflowState & {...}, unsigned int &
0x00000000) line 439 + 28 bytes
nsMenuFrame::Reflow(nsMenuFrame * const 0x028dda14, nsIPresContext & {...},
nsHTMLReflowMetrics & {...}, const nsHTMLReflowState & {...}, unsigned int &
0x00000000) line 483 + 34 bytes
nsBoxFrame::FlowChildAt(nsIFrame * 0x028dda10, nsIPresContext & {...},
nsHTMLReflowMetrics & {...}, const nsHTMLReflowState & {...}, unsigned int &
0x00000000, nsCalculatedBoxInfo & {...}, int & 0x00000001, nsString & {...})
line 863
nsBoxFrame::FlowChildren(nsIPresContext & {...}, nsHTMLReflowMetrics & {...},
const nsHTMLReflowState & {...}, unsigned int & 0x00000000, nsRect & {...}) line
494
nsBoxFrame::Reflow(nsBoxFrame * const 0x028d520c, nsIPresContext & {...},
nsHTMLReflowMetrics & {...}, const nsHTMLReflowState & {...}, unsigned int &
0x00000000) line 354
nsContainerFrame::ReflowChild(nsIFrame * 0x028d5208, nsIPresContext & {...},
nsHTMLReflowMetrics & {...}, const nsHTMLReflowState & {...}, unsigned int &
0x00000000) line 439 + 28 bytes
nsMenuFrame::Reflow(nsMenuFrame * const 0x028d36d4, nsIPresContext & {...},
nsHTMLReflowMetrics & {...}, const nsHTMLReflowState & {...}, unsigned int &
0x00000000) line 483 + 34 bytes
nsBoxFrame::FlowChildAt(nsIFrame * 0x028d36d0, nsIPresContext & {...},
nsHTMLReflowMetrics & {...}, const nsHTMLReflowState & {...}, unsigned int &
0x00000000, nsCalculatedBoxInfo & {...}, int & 0x00000001, nsString & {...})
line 863
nsBoxFrame::FlowChildren(nsIPresContext & {...}, nsHTMLReflowMetrics & {...},
const nsHTMLReflowState & {...}, unsigned int & 0x00000000, nsRect & {...}) line
494
nsBoxFrame::Reflow(nsBoxFrame * const 0x00d2ad54, nsIPresContext & {...},
nsHTMLReflowMetrics & {...}, const nsHTMLReflowState & {...}, unsigned int &
0x00000000) line 354
nsBoxFrame::FlowChildAt(nsIFrame * 0x00d2ad50, nsIPresContext & {...},
nsHTMLReflowMetrics & {...}, const nsHTMLReflowState & {...}, unsigned int &
0x00000000, nsCalculatedBoxInfo & {...}, int & 0x00000000, nsString & {...})
line 863
nsBoxFrame::FlowChildren(nsIPresContext & {...}, nsHTMLReflowMetrics & {...},
const nsHTMLReflowState & {...}, unsigned int & 0x00000000, nsRect & {...}) line
494
nsBoxFrame::Reflow(nsBoxFrame * const 0x00d28df4, nsIPresContext & {...},
nsHTMLReflowMetrics & {...}, const nsHTMLReflowState & {...}, unsigned int &
0x00000000) line 354
nsContainerFrame::ReflowChild(nsIFrame * 0x00d28df0, nsIPresContext & {...},
nsHTMLReflowMetrics & {...}, const nsHTMLReflowState & {...}, unsigned int &
0x00000000) line 439 + 28 bytes
RootFrame::Reflow(RootFrame * const 0x026f0b24, nsIPresContext & {...},
nsHTMLReflowMetrics & {...}, const nsHTMLReflowState & {...}, unsigned int &
0x00000000) line 327
nsContainerFrame::ReflowChild(nsIFrame * 0x026f0b20, nsIPresContext & {...},
nsHTMLReflowMetrics & {...}, const nsHTMLReflowState & {...}, unsigned int &
0x00000000) line 439 + 28 bytes
ViewportFrame::Reflow(ViewportFrame * const 0x026e7914, nsIPresContext & {...},
nsHTMLReflowMetrics & {...}, const nsHTMLReflowState & {...}, unsigned int &
0x00000000) line 513
PresShell::InitialReflow(PresShell * const 0x025ff030, int 0x000005dc, int
0x0000040b) line 815
XULDocumentImpl::StartLayout() line 4022
XULDocumentImpl::EndLoad(XULDocumentImpl * const 0x025cc680) line 1897
XULContentSinkImpl::DidBuildModel(XULContentSinkImpl * const 0x025cdb90, int
0x00000001) line 558
CWellFormedDTD::DidBuildModel(CWellFormedDTD * const 0x02600a00, unsigned int
0x00000000, int 0x00000001, nsIParser * 0x025cd5c0, nsIContentSink * 0x025cdb90)
line 287 + 20 bytes
nsParser::DidBuildModel(unsigned int 0x00000000) line 525 + 55 bytes
nsParser::ResumeParse(nsIDTD * 0x00000000, int 0x00000000) line 893
nsParser::EnableParser(int 0x00000001) line 619 + 15 bytes
XULContentSinkImpl::DoneLoadingScript(nsIUnicharStreamLoader * 0x026514e0,
nsString & {...}, void * 0x025cdb90, unsigned int 0x00000000) line 1688
nsUnicharStreamLoader::OnStopRequest(nsUnicharStreamLoader * const 0x026514e4,
nsIChannel * 0x02652c00, nsISupports * 0x00000000, unsigned int 0x00000000,
const unsigned short * 0x00000000) line 159 + 31 bytes
nsOnStopRequestEvent::HandleEvent(nsOnStopRequestEvent * const 0x02653c30) line
269
nsStreamListenerEvent::HandlePLEvent(PLEvent * 0x02653c34) line 144 + 12 bytes
PL_HandleEvent(PLEvent * 0x02653c34) line 509 + 10 bytes
PL_ProcessPendingEvents(PLEventQueue * 0x00b038d0) line 470 + 9 bytes
_md_EventReceiverProc(HWND__ * 0x446901d6, unsigned int 0x0000c0b1, unsigned int
0x00000000, long 0x00b038d0) line 938 + 9 bytes
USER32! 77e71268()
maybe a dup of 11474, except that 11474 isn't a crash, just an assert...
Status: NEW → RESOLVED
Closed: 20 years ago
Resolution: --- → DUPLICATE
Summary: Apprunner crashes → Apprunner asserts on startup
Well sorry, it is an assertion rather than a crash, but it makes
apprunner totally unusable for me.

marking as a dup.

*** This bug has been marked as a duplicate of 11474 ***
QA Contact: ckritzer → jband
Assigning to originator per new organizational structure.
QA Contact: jband → ckritzer
Changing QA Contact back to ckritzer@netscape.com
Status: RESOLVED → VERIFIED
Marking VERIFIED DUPLICATE per jband's comments.
BULK MOVE: Changing component from XUL to XP Toolkit/Widgets: XUL.  XUL 
component will be deleted.
Component: XUL → XP Toolkit/Widgets: XUL
Component: XP Toolkit/Widgets: XUL → XUL
QA Contact: ckritzer → xptoolkit.widgets
You need to log in before you can comment on or make changes to this bug.