If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Address list always crashes, always corrupt, leaves blank addresses, routing loop

VERIFIED DUPLICATE of bug 119595

Status

SeaMonkey
MailNews: Address Book & Contacts
--
critical
VERIFIED DUPLICATE of bug 119595
16 years ago
13 years ago

People

(Reporter: John Fredlund, Assigned: racham)

Tracking

({crash})

Trunk
x86
Windows ME
crash

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

16 years ago
Build 2002020206, but has persisted for too many builds.
TB2709531M, TB2709488X, TB2646647M, TB2646597G

Working with long address list, deleted and recreated (with new name) several
times - list is always corrupted. Get message from mail daemon "The MMS SMTP
Relay is returning your message because:	A routing loop has been detected for this
message."

Try to use slider bar to scroll through addresses in list edit window always
crashes. If try to remove bad address from list, leaves blank address in list.
Cannot get rid of blank address - Trying to often causes crash. Can't have
capital letters in address (I know this part is dupe, but time for a rollup
critical bug here, you can't release a build called 1.0 without fixing all
these). Can't resize address list editing window.

Mozilla is a great piece of work, except this one bug area REALLY hurts. I don't
have NS4 any more, won't use any MS product, so I am crippled by lack of ability
to have an address list.
(Reporter)

Comment 1

16 years ago
Adding keywords buzilla did not let me do before.
Keywords: crash, mail3, nsCatFood

Comment 2

16 years ago
Please submit only one issue per bug.
The crash is bug 110165 - resolving as duplicate.

*** This bug has been marked as a duplicate of 110165 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 3

16 years ago
Please reopen - triaged correctly. This bug is in the address book component,
not composition (see component field above).

I searched for bugs that covered the severity of problems, and only found bits
and pieces. I felt it was time to collect all the big problems to show a bug
that would get more attention. Lack of address book address list ability
seriously impacts the usability of Mozilla.
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---

Comment 4

16 years ago
oops. possibly dup of 119595 or bug 124261.
Stephen: can you pull TB2709531M
0x0201c9ef
nsHTMLInputElement::SetValueSecure
[d:\builds\seamonkey\mozilla\content\html\content\src\nsHTMLInputElement.cpp,
line 516]
nsHTMLInputElement::SetValue
[d:\builds\seamonkey\mozilla\content\html\content\src\nsHTMLInputElement.cpp,
line 468]
nsHTMLInputElement::RestoreState
[d:\builds\seamonkey\mozilla\content\html\content\src\nsHTMLInputElement.cpp,
line 2023]
nsFormControlHelper::RestoreContentState
[d:\builds\seamonkey\mozilla\layout\html\forms\src\nsFormControlHelper.cpp, line
1078]
nsGfxTextControlFrame2::RestoreState
[d:\builds\seamonkey\mozilla\layout\html\forms\src\nsGfxTextControlFrame2.cpp,
line 3539]
FrameManager::RestoreFrameStateFor
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsFrameManager.cpp, line 2346]
nsCSSFrameConstructor::InitAndRestoreFrame
[d:\builds\seamonkey\mozilla\layout\html\style\src\nsCSSFrameConstructor.cpp,
line 6422]
nsCSSFrameConstructor::ConstructHTMLFrame
[d:\builds\seamonkey\mozilla\layout\html\style\src\nsCSSFrameConstructor.cpp,
line 4624]
nsCSSFrameConstructor::ConstructFrameInternal
[d:\builds\seamonkey\mozilla\layout\html\style\src\nsCSSFrameConstructor.cpp,
line 6993]
nsCSSFrameConstructor::ConstructFrame
[d:\builds\seamonkey\mozilla\layout\html\style\src\nsCSSFrameConstructor.cpp,
line 6888]
nsCSSFrameConstructor::ProcessChildren
[d:\builds\seamonkey\mozilla\layout\html\style\src\nsCSSFrameConstructor.cpp,
line 11890]
nsCSSFrameConstructor::ConstructXULFrame
[d:\builds\seamonkey\mozilla\layout\html\style\src\nsCSSFrameConstructor.cpp,
line 5528]
nsCSSFrameConstructor::ConstructFrameInternal
[d:\builds\seamonkey\mozilla\layout\html\style\src\nsCSSFrameConstructor.cpp,
line 6997]
nsCSSFrameConstructor::ConstructFrame
[d:\builds\seamonkey\mozilla\layout\html\style\src\nsCSSFrameConstructor.cpp,
line 6888]
nsCSSFrameConstructor::ProcessChildren
[d:\builds\seamonkey\mozilla\layout\html\style\src\nsCSSFrameConstructor.cpp,
line 11890]
nsCSSFrameConstructor::ConstructXULFrame
[d:\builds\seamonkey\mozilla\layout\html\style\src\nsCSSFrameConstructor.cpp,
line 5528]
nsCSSFrameConstructor::ConstructFrameInternal
[d:\builds\seamonkey\mozilla\layout\html\style\src\nsCSSFrameConstructor.cpp,
line 6997]
nsCSSFrameConstructor::ConstructFrameInternal
[d:\builds\seamonkey\mozilla\layout\html\style\src\nsCSSFrameConstructor.cpp,
line 6949]
nsCSSFrameConstructor::ConstructFrame
[d:\builds\seamonkey\mozilla\layout\html\style\src\nsCSSFrameConstructor.cpp,
line 6888]
nsCSSFrameConstructor::ProcessChildren
[d:\builds\seamonkey\mozilla\layout\html\style\src\nsCSSFrameConstructor.cpp,
line 11890]
nsCSSFrameConstructor::ConstructXULFrame
[d:\builds\seamonkey\mozilla\layout\html\style\src\nsCSSFrameConstructor.cpp,
line 5528]
nsCSSFrameConstructor::ConstructFrameInternal
[d:\builds\seamonkey\mozilla\layout\html\style\src\nsCSSFrameConstructor.cpp,
line 6997]
nsCSSFrameConstructor::ConstructFrame
[d:\builds\seamonkey\mozilla\layout\html\style\src\nsCSSFrameConstructor.cpp,
line 6888]
nsCSSFrameConstructor::ProcessChildren
[d:\builds\seamonkey\mozilla\layout\html\style\src\nsCSSFrameConstructor.cpp,
line 11890]
nsCSSFrameConstructor::ConstructXULFrame
[d:\builds\seamonkey\mozilla\layout\html\style\src\nsCSSFrameConstructor.cpp,
line 5528]
nsCSSFrameConstructor::ConstructFrameInternal
[d:\builds\seamonkey\mozilla\layout\html\style\src\nsCSSFrameConstructor.cpp,
line 6997]
nsCSSFrameConstructor::CreateTreeWidgetContent
[d:\builds\seamonkey\mozilla\layout\html\style\src\nsCSSFrameConstructor.cpp,
line 12917]
nsXULTreeGroupFrame::GetFirstTreeBox
[d:\builds\seamonkey\mozilla\layout\xul\base\src\nsXULTreeGroupFrame.cpp, line 329]
nsTreeLayout::LazyRowCreator
[d:\builds\seamonkey\mozilla\layout\xul\base\src\nsTreeLayout.cpp, line 363]
nsTreeLayout::LazyRowCreator
[d:\builds\seamonkey\mozilla\layout\xul\base\src\nsTreeLayout.cpp, line 374]
nsXULTreeOuterGroupFrame::ReflowFinished
[d:\builds\seamonkey\mozilla\layout\xul\base\src\nsXULTreeOuterGroupFrame.cpp,
line 1351]
PresShell::HandlePostedReflowCallbacks
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsPresShell.cpp, line 4945]
PresShell::ProcessReflowCommands
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsPresShell.cpp, line 6319]
PresShell::FlushPendingNotifications
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsPresShell.cpp, line 5039]
nsXULTreeOuterGroupFrame::InternalPositionChanged
[d:\builds\seamonkey\mozilla\layout\xul\base\src\nsXULTreeOuterGroupFrame.cpp,
line 809]
nsXULTreeOuterGroupFrame::EnsureRowIsVisible
[d:\builds\seamonkey\mozilla\layout\xul\base\src\nsXULTreeOuterGroupFrame.cpp,
line 1220]
nsXULTreeFrame::EnsureRowIsVisible
[d:\builds\seamonkey\mozilla\layout\xul\base\src\nsXULTreeFrame.cpp, line 140]
nsTreeBoxObject::EnsureIndexIsVisible
[d:\builds\seamonkey\mozilla\layout\xul\base\src\nsTreeBoxObject.cpp, line 100]
XPTC_InvokeByIndex
[d:\builds\seamonkey\mozilla\xpcom\reflect\xptcall\src\md\win32\xptcinvoke.cpp,
line 106]
XPCWrappedNative::CallMethod
[d:\builds\seamonkey\mozilla\js\src\xpconnect\src\xpcwrappednative.cpp, line 2000]
XPC_WN_CallMethod
[d:\builds\seamonkey\mozilla\js\src\xpconnect\src\xpcwrappednativejsops.cpp,
line 1267]
js_Invoke [d:\builds\seamonkey\mozilla\js\src\jsinterp.c, line 834]
js_Interpret [d:\builds\seamonkey\mozilla\js\src\jsinterp.c, line 2799]
js_Execute [d:\builds\seamonkey\mozilla\js\src\jsinterp.c, line 1014]
JS_EvaluateUCScriptForPrincipals [d:\builds\seamonkey\mozilla\js\src\jsapi.c,
line 3358]
nsJSContext::EvaluateString
[d:\builds\seamonkey\mozilla\dom\src\base\nsJSEnvironment.cpp, line 687]
GlobalWindowImpl::RunTimeout
[d:\builds\seamonkey\mozilla\dom\src\base\nsGlobalWindow.cpp, line 3861]
GlobalWindowImpl::TimerCallback
[d:\builds\seamonkey\mozilla\dom\src\base\nsGlobalWindow.cpp, line 4187]
nsTimerImpl::Process [d:\builds\seamonkey\mozilla\xpcom\threads\nsTimerImpl.cpp,
line 247]
handleMyEvent [d:\builds\seamonkey\mozilla\xpcom\threads\nsTimerImpl.cpp, line 287]
PL_HandleEvent [d:\builds\seamonkey\mozilla\xpcom\threads\plevent.c, line 591]
PL_ProcessPendingEvents [d:\builds\seamonkey\mozilla\xpcom\threads\plevent.c,
line 524]
_md_EventReceiverProc [d:\builds\seamonkey\mozilla\xpcom\threads\plevent.c, line
1072]
KERNEL32.DLL + 0x248f7 (0xbff848f7)
0x00648c16
0x00058f64 

Comment 6

16 years ago
well it's identical to one of the stacks from bug 110165 - see comment:
http://bugzilla.mozilla.org/show_bug.cgi?id=110165#c11

Leaving to someone else to dup it this time.

Comment 7

16 years ago

*** This bug has been marked as a duplicate of 119595 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago16 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 8

16 years ago
The address list corruption is also very serious. I do not see a bug covering
that part of this overall issue. I wonder if the corruption causes bug 119595?

Before I found out about the corruption, I used the list (I had not tried
scrolling!) and ended up spamming many people with multiple copies of the same
email. The complaint I received mentioned 4 copies.

Comment 9

16 years ago
John Fredlund: Thanks for filing bugs. To keep bugzilla somewhat managable:
Please submit only one issue per bug-report.

If you think issues here are not covered in bugzilla, please file new reports.
Your summary and keywords here indicate a crash as the main issue.
The crash is a duplicate of bug 119595.

A recent bug about AB corruption was filed in bug 124498.
If you have additional information that can be relevant for that bug, please do
add a comment there.

Also of relevance:
Was the AB imported? Created from scratch in Mozilla 0.9.8?
Do you see the bug under both the classic and modern theme?
Do you use multiple mozilla-based applications utilizing the same profile?
Does the bug also occure if you test it with a clean profile?
Etc.

Comment 10

16 years ago
Verified duplicate.
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.