INFO TEST-UNEXPECTED-FAIL | browser/base/content/test/chat/browser_chatwindow.js | This test exceeded the timeout threshold

RESOLVED FIXED in Firefox 46

Status

defect
P1
normal
Rank:
19
RESOLVED FIXED
3 years ago
3 years ago

People

(Reporter: standard8, Assigned: mikedeboer)

Tracking

({regression})

unspecified
mozilla47
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox45 wontfix, firefox46 fixed, firefox47 fixed, firefox48 fixed, firefox-esr45 fixed)

Details

(Whiteboard: [btpp-fix-now])

Attachments

(2 attachments)

Reporter

Description

3 years ago
Looks like the push of bug  caused a frequent intermittent failures:

https://treeherder.mozilla.org/#/jobs?repo=fx-team&selectedJob=7053655

10:04:17     INFO -  85 INFO TEST-PASS | browser/base/content/test/chat/browser_chatwindow.js | Button should have been commanded once - 1 == 1 -
10:04:17     INFO -  86 INFO Finished chat test testCustomButton - cleaning up.
10:04:17     INFO -  87 INFO Leaving test
10:04:17     INFO -  88 INFO Console message: [JavaScript Error: "TypeError: content is null" {file: "chrome://browser/content/social-content.js" line: 62}]
10:04:17     INFO -  89 INFO TEST-UNEXPECTED-FAIL | browser/base/content/test/chat/browser_chatwindow.js | This test exceeded the timeout threshold. It should be rewritten or split up. If that's not possible, use requestLongerTimeout(N), but only as a last resort. -
10:04:17     INFO -  MEMORY STAT vsizeMaxContiguous not supported in this build configuration.
10:04:17     INFO -  MEMORY STAT | vsize 681MB | residentFast 251MB | heapAllocated 84MB
10:04:17     INFO -  90 INFO TEST-OK | browser/base/content/test/chat/browser_chatwindow.js | took 46485ms

It looks like the test ran, but then failed at the end for some strange reason...

Probably Linux debug builds only.
Reporter

Comment 1

3 years ago
https://hg.mozilla.org/integration/fx-team/rev/349a2612c171f29b445f4f8735b4450ae8b21f71
Bug 1245937 - Disable browser_chat_window.js for test failures frallout from bug 1154277. rs=orange-fix CLOSED TREE
Reporter

Comment 2

3 years ago
I've marked the test as skipped for now, since I don't see an impact elsewhere, but we should probably fix this one as soon as we can.
Reporter

Updated

3 years ago
Blocks: 1154277
Assignee

Comment 3

3 years ago
Thanks Mark, for landing this follow-up so quickly! I will take this up tomorrow morning, first thing.

Comment 4

3 years ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/349a2612c171
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla47
Reporter

Comment 5

3 years ago
Whoops forgot the leave open
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Assignee

Updated

3 years ago
Status: REOPENED → ASSIGNED
Rank: 19
Assignee

Updated

3 years ago
Depends on: 1229195
Assignee

Comment 8

3 years ago
This was fixed by the patch in bug 1229195.
Reporter

Comment 10

3 years ago
Comment on attachment 8718364 [details] [diff] [review]
Patch v1: re-enable browser_chatwindow.js mochitest

We don't need to wait for the loop part of bug 1229195 to land do we? Assuming not, then r=Standard8
Attachment #8718364 - Flags: review?(standard8) → review+
Assignee

Comment 11

3 years ago
neup.
Mike: what's the status of this?
Flags: needinfo?(mdeboer)
Assignee

Comment 15

3 years ago
Once bug 1229195 has landed, this test can be re-enabled after confirming things on Try.
Flags: needinfo?(mdeboer)
Assignee

Comment 16

3 years ago
https://hg.mozilla.org/integration/fx-team/rev/6d20cb4a0dd85df647eb0e27c6c099d7439fd217
Bug 1245937 - requestLongerTimeout for browser_chatwindow.js and browser_focus.js since 1154277 slowed them down, transplanted from mozilla-aurora. rs=testonly

Comment 17

3 years ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/6d20cb4a0dd8
Status: ASSIGNED → RESOLVED
Closed: 3 years ago3 years ago
Resolution: --- → FIXED
Reporter

Comment 19

3 years ago
Mike, comment 17 seemed to transplant the requestLongerTimeout, but didn't actually re-land the enabling of the test?

Can you take a look please?
Status: RESOLVED → REOPENED
Flags: needinfo?(mdeboer)
Resolution: FIXED → ---
Assignee

Comment 20

3 years ago
Ahum, you're entirely correct, sir.
Flags: needinfo?(mdeboer)
Assignee

Updated

3 years ago
Status: REOPENED → ASSIGNED
Reporter

Updated

3 years ago
Attachment #8728367 - Flags: review?(standard8) → review+

Comment 23

3 years ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/a437a0f043b6
Status: ASSIGNED → RESOLVED
Closed: 3 years ago3 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.