crash in mozilla::MediaPipelineFactory::ConfigureVideoCodecMode

RESOLVED DUPLICATE of bug 1259236

Status

()

Core
WebRTC
P1
critical
Rank:
15
RESOLVED DUPLICATE of bug 1259236
2 years ago
2 years ago

People

(Reporter: Philipp Hancke, Assigned: jib)

Tracking

44 Branch
Unspecified
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(crash signature)

Attachments

(2 attachments)

(Reporter)

Description

2 years ago
Created attachment 8716030 [details]
crashed attempting to renegotiate

This bug was filed from the Socorro interface and is 
report bp-26e02a01-76b3-4b4e-8312-cc06a2160204.
=============================================================

Comment 1

2 years ago
Here's a crash report from Nightly:

https://crash-stats.mozilla.com/report/index/ad9fd207-f1a4-47cc-acdd-1446c2160204

Looks media-related, although maybe MediaPipelineFactory is using the API wrong.
Flags: needinfo?(rjesup)

Updated

2 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Reporter)

Comment 2

2 years ago
Possibly related: removing the 
        origStream.addTrack(stream.getTracks()[0]); // Firefox
makes it not crash. FF47 takes quite some time to emit a
        InvalidParameterError: track is not in stream.

Does not make things renegotiate however.
backlog: --- → webrtc/webaudio+
Rank: 15
Priority: -- → P1
(Reporter)

Comment 3

2 years ago
pragmatic workaround: don't add to the existing stream but a new one, then munge the stream ids so the remote side sees only a single stream and adds a track.
So the issue is that MediaPipelineFactory::ConfigureVideoCodecMode() is being called for a stream without video (no surprise, it was audio-only before), so there's no video engine to return, leading to a null-deref.  Likely it's an order-of-operations thing, or not updating the nsDOMUseMediaStream properly when adding video to it.

This is easy to debug using rr, note. :-)

A MOZ_ASSERT for an engine being returned is something we should add in resolving this.
Assignee: nobody → docfaraday
Flags: needinfo?(rjesup)
Jib -- can I ask you to look at this once you've finished with the getSettings()bug?
Assignee: docfaraday → jib
This appears to have been fixed by bug 1259236 (47 beta) according to mozregression --find-fix:

20:08.29 INFO: First good revision: 6dbd1b04414da30241642900d6c68155115093aa
20:08.29 INFO: Last bad revision: c9e6dcefcfe85e0613f940d04493add4ec685af8
20:08.29 INFO: Pushlog:
https://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=c9e6dcefcfe85e0613f940d04493add4ec685af8&tochange=6dbd1b04414da30241642900d6c68155115093aa

and I also see this in web console when it doesn't crash:

 NotSupportedError: track in constructed stream not yet supported (see Bug 1259236).

which is the wallpaper fix from that bug.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1259236
You need to log in before you can comment on or make changes to this bug.