McAfee SiteAdvisor extension wipes out Add-ons/Extensions page

RESOLVED INVALID

Status

()

Toolkit
Add-ons Manager
P3
normal
RESOLVED INVALID
3 years ago
2 years ago

People

(Reporter: Andreas Troschka, Unassigned)

Tracking

44 Branch
x86_64
Windows 10
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: triaged)

Attachments

(1 attachment)

74.31 KB, application/octet-stream
Details
(Reporter)

Description

3 years ago
User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:44.0) Gecko/20100101 Firefox/44.0
Build ID: 20160123151951

Steps to reproduce:

Windows 10 Pro Build10586.
McAfee product LiveSafe autoupdated. 
The plugin C:\Program Files (x86)\McAfee\SiteAdvisor\saffplg.xpi v4.0.20 is now installed.

Opened Add-ons, then Extensions.


Actual results:

Despite plugins are already present (some are visible on the toolbar) and are functioning, they are no more shown in the Extensions page, making it impossible to manage them in any way.



Expected results:

Normal listing of plugins.


Note: Renaming the file saffplg.xpi and restarting FF removes the SiteAdvisor functionality but the Extensions page is again populated with the (DISABLED!) plugins list. Reenabling them restores the situation.

Comment 1

3 years ago
I guess this add-on uses some CSS hacks to hide itself in the add-on manager, against the rules.
Component: Untriaged → Add-ons Manager
Product: Firefox → Toolkit
(Reporter)

Comment 2

3 years ago
This maybe an issue due to the McAfee's saffplg.xpi plugin itself.
Can you attach the XPI file to this bug report?
Flags: needinfo?(signupbox01)
(Reporter)

Comment 4

3 years ago
Created attachment 8716470 [details]
McAfee plugin
Flags: needinfo?(signupbox01)
(Reporter)

Updated

3 years ago
OS: Unspecified → Windows 10
Hardware: Unspecified → x86_64
N.B. (@Andreas) In Mozilla terminology, a "plugin" or an "NPAPI plugin" is the kind of stuff listed in the Plugins pane of the add-ons manager, or in about:plugins (Flash is an example). XPI files can be extensions, themes, language packs, or in general "add-ons" but not plugins.
Summary: McAfee SiteAdvisor plugin wipes Add-ons/Extensions page → McAfee SiteAdvisor extension wipes out Add-ons/Extensions page
Comment hidden (off-topic)

Comment 7

2 years ago
Jorge, can you take a look and see what this add-on is doing that is off?
Flags: needinfo?(jorge)
I don't see anything in the add-on code specifically targeting the Add-ons Manager. The code is minified though, so I could be wrong. There's some CSS manipulation happening, so there could be a bug in the way that is applied. I couldn't reproduce the bug by installing the xpi on Mac OS.

I'll contact the developers about this.
Flags: needinfo?(jorge)

Comment 9

2 years ago
We will check the issue. There is nothing done in the plug-in targeting Add-ons Manager or to hide from Add-on manager.

Comment 10

2 years ago
Krupa will try to replicate on windows 10 -
Flags: needinfo?(krupa.mozbugs)
Priority: -- → P3
Whiteboard: triaged

Comment 11

2 years ago
Verified this on:
1) User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:44.0) Gecko/20100101 Firefox/44.0
Build ID: 20160120154102
&
2) User Agent  Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:44.0) Gecko/20100101 Firefox/44.0
Build ID  20160123151951

and could not reproduce it.

Downloaded the attached .xpi and submitted using AMO-stage. 
You can see the extension here: https://addons.allizom.org/en-US/firefox/addon/mcafee-webadvisor/

Results after installation of "McAfee WebAdvisor":
- the extension is listed in about:addons Extensions pane (http://screencast.com/t/vwXhyeJ9Jo)
- details about the extension can be seen (http://screencast.com/t/du6lt6Ax66)
- installing other add-ons (normal add-ons, webextensions) does not brake the extension or the discovery pane
- restarting the FF browser has the expected behavior

Please let us now if there is some other step that we missed in order to reproduce this.
Flags: needinfo?(krupa.mozbugs)
Closing this due to lack of reliable STR.

@Andreas Troschka: if you have more detailed steps we can try, please post them here and we will reopen the bug.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → INVALID
(Reporter)

Comment 13

2 years ago
Looking at Windows' update logs I found something suspicious. Around the same time FF started to show the washed extension page, object of this bug, a Windows auto-update was performed.
So I've decided to make a test.

a) Fresh install of Windows 10 Pro, updated as at time FF showed the malfunction;
b) On another partition fresh install of Windows and full update to actual version.

FF and McAfee extension (versions as mentioned in this thread) installed on both partitions.

Results:

a) Extension page in FF washed as mentioned;
b) FF works as expected; extension page shows the Mcafee extension (the only installed) as it should do.

I've no clue what the problem is, therefore it appears that something, in the older update setup (build) of Windows 10 triggers the misbehaviour in FF.

As the problem is disappeared with the Windows last update, I would consider this bug solved.

Thank's to all for the efforts.

Andreas Troschka
You need to log in before you can comment on or make changes to this bug.