bugzilla.mozilla.org has resumed normal operation. Attachments prior to 2014 will be unavailable for a few days. This is tracked in Bug 1475801.
Please report any other irregularities here.

nsIZipReader and GitHub are not friendly enough: /install-plugin fails due to read-only files

RESOLVED DUPLICATE of bug 1030029

Status

Other Applications
ChatZilla
RESOLVED DUPLICATE of bug 1030029
3 years ago
3 years ago

People

(Reporter: James Ross, Assigned: Robert Ginda)

Tracking

Trunk
All
Windows

Firefox Tracking Flags

(firefox47 affected)

Details

(Reporter)

Description

3 years ago
Due to GitHub's repository zips having empty permissions (I presume just 0 is stored) and bug 935553 (maybe) meaning that nsIZipReader extracts such files as read-only on Windows, /install-plugin fails catastrophically:

[22:14:20]	[INFO]	Downloading plugin from 'https://github.com/twpol/cz-plugin-network-trace/archive/master.zip'…
[22:14:21]	[INFO]	Installing from 'C:\Users\James\AppData\Roaming\ChatZilla\Profiles\0n2xrybw.default\chatzilla\plugin-install.temp.zip' to 'E:\Documents\Coding\ChatZilla\Scripts'…
	[ERROR]	An error occurred extracting the compressed source: [Exception... "Component returned failure code: 0x80520015 (NS_ERROR_FILE_ACCESS_DENIED) [nsILocalFile.remove]"  nsresult: "0x80520015 (NS_ERROR_FILE_ACCESS_DENIED)"  location: "JS frame :: chrome://chatzilla/content/static.js :: cli_installPlugin :: line 3329"  data: no]

The line the error occurs on is where we're removing the temporary copy of init.js (to extract the plugin ID) but, even if we fix that one, all the files will be read-only which will mess up any updated or other operations.

We should deliberately override permissions to avoid read-only files.
see Bug 1030029
(Reporter)

Updated

3 years ago
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1030029
You need to log in before you can comment on or make changes to this bug.