Status

MailNews Core
Composition
--
critical
RESOLVED WORKSFORME
17 years ago
10 years ago

People

(Reporter: Tim Johnson, Assigned: asa)

Tracking

({hang})

Trunk
mozilla1.0
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:0.9.8+)
Gecko/20020208
BuildID:    2002020803

Twice now while composing a reply to an e-mail, Mozilla hung with a 100% cpu
usage. Both times, it occurred after I had pressed Enter to end a paragraph, and
just as I typed the first character of the new paragraph.  This does not happen
for every paragraph and so far, I have not been able to reproduce it reliabilly.

I'm not sure whether it's only a reply (I have the preference set to quote the
e-mail I'm replying to), or for all e-mail compositions.

Reproducible: Sometimes
Steps to Reproduce:
1.Type some paragraphs in a reply.
2.Hope the start of a new paragraph will cause the hang with 100% cpu.


Actual Results:  Mozilla hangs with 100% cpu usage.

Expected Results:  Continue to compose e-mail.
(Reporter)

Comment 1

17 years ago
Still no consistant way to reproduce this, but I've found it doesn't matter
whether it's a reply or new note. I've gotten it to happen several times since
my first report. Sometimes it takes a considerable amount of typing, and other
times, it happens very soon. It does happen enough that with some patience, it
should occur within a reasonable time.

Comment 2

17 years ago
same here. i'm also running XP

Comment 3

17 years ago
shouldn't the component of this bug be 'editor-composer'?

Comment 4

17 years ago
likely dup of bug 124209 (by way of bug 124209)

(Reporter)

Comment 5

17 years ago
I'm not sure this is a dup of 124209, since I've seen the hang on a fresh
compose (not a reply) which for me is plain text. When 124209 is in a nightly,
and I don't see my hangs, I'll agree it was a dup.

Comment 6

17 years ago
i'm getting it on today's build (20020220xx) on linux.  sorry i don't know the
xx; i've reverted to 2002021821 and the problem seems to go away..  seems to
have nothing to do with bug 124209, as i'm not selecting anything, deleting
anything, and i'm not using plain-text reply mode.

Comment 7

17 years ago
I'm getting this too on a build from yesterday (linux), each time I try to paste
a line starting with a <tab>...

Comment 8

17 years ago
dup of bug 126558?
(Reporter)

Comment 9

17 years ago
I don't think this is a dup of bug 126558. With the hang I see no tab was
entered, and I did not get high cpu usage. In fact I am able to close the
composer window, and start a new one and continue working. However, in the
composer window in which the hang occurred, I can do nothing. It's especially
bad because I can't do a copy of the text to preserve what I've already typed. I
have to re-enter it all.

It's possible that what Dennis Haney is seeing is a dup of bug 126558 since it
involves use of the tab character.

Comment 10

16 years ago
--> Mail/News
Component: Browser-General → Composition
Product: Browser → MailNews
Target Milestone: --- → mozilla1.0

Updated

16 years ago
Severity: normal → critical
Keywords: hang

Comment 11

16 years ago
WinXP / 2002053012 / JRE 1.4.0-rc

WFM, also this bug was encountered using an old (3+ weeks) build of Mozilla, if
this bug persists using a current build, please get this bug reopened.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → WORKSFORME
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.