[e10s] Jetpack tests permafail with e10s enabled | TypeError: tab is null

RESOLVED DUPLICATE of bug 1232643

Status

defect
P4
normal
RESOLVED DUPLICATE of bug 1232643
4 years ago
3 years ago

People

(Reporter: jgriffin, Unassigned)

Tracking

(Blocks 1 bug)

unspecified
Dependency tree / graph

Firefox Tracking Flags

(e10s+)

Details

(Whiteboard: triaged)

The jetpack mochitest suite is permafail on Windows 7:

 00:30:42     INFO -  TEST-START | test-addon-manager/main.test getAddonByID
 00:30:42     INFO -  TEST-PASS | test-addon-manager/main.test getAddonByID | getAddonByID works
 00:30:42     INFO -  TEST-PASS | test-addon-manager/main.test getAddonByID | This test is done.
 00:30:42     INFO -  *************************
 00:30:42     INFO -  A coding exception was thrown in a Promise resolution callback.
 00:30:42     INFO -  See https://developer.mozilla.org/Mozilla/JavaScript_code_modules/Promise.jsm/Promise
 00:30:42     INFO -  Full message: TypeError: tab is null
 00:30:42     INFO -  Full stack: getTabId@resource://gre/modules/commonjs/toolkit/loader.js -> resource://gre/modules/commonjs/sdk/tabs/utils.js:206:1
 00:30:42     INFO -  done/<@resource://gre/modules/commonjs/toolkit/loader.js -> resource://gre/modules/commonjs/sdk/deprecated/unit-test.js:335:22
 00:30:42     INFO -  Handler.prototype.process@resource://gre/modules/Promise.jsm -> resource://gre/modules/Promise-backend.js:937:23
 00:30:42     INFO -  this.PromiseWalker.walkerLoop@resource://gre/modules/Promise.jsm -> resource://gre/modules/Promise-backend.js:816:7
 00:30:42     INFO -  Promise*this.PromiseWalker.scheduleWalkerLoop@resource://gre/modules/Promise.jsm -> resource://gre/modules/Promise-backend.js:747:11
 00:30:42     INFO -  this.PromiseWalker.schedulePromise@resource://gre/modules/Promise.jsm -> resource://gre/modules/Promise-backend.js:779:7
 00:30:42     INFO -  this.PromiseWalker.completePromise@resource://gre/modules/Promise.jsm -> resource://gre/modules/Promise-backend.js:714:7
 00:30:42     INFO -  checkForCompletion@resource://gre/modules/Promise.jsm -> resource://gre/modules/Promise-backend.js:571:9
 00:30:42     INFO -  Promise.all/</resolver@resource://gre/modules/Promise.jsm -> resource://gre/modules/Promise-backend.js:578:29
 00:30:42     INFO -  promise callback*Promise.all/<@resource://gre/modules/Promise.jsm -> resource://gre/modules/Promise-backend.js:581:9
 00:30:42     INFO -  Promise@resource://gre/modules/Promise.jsm -> resource://gre/modules/Promise-backend.js:388:5
 00:30:42     INFO -  Promise.all@resource://gre/modules/Promise.jsm -> resource://gre/modules/Promise-backend.js:558:10
 00:30:42     INFO -  done@resource://gre/modules/commonjs/toolkit/loader.js -> resource://gre/modules/commonjs/sdk/deprecated/unit-test.js:332:12
 00:30:42     INFO -  assert.end@resource://gre/modules/commonjs/toolkit/loader.js -> resource://gre/modules/commonjs/sdk/test.js:48:30
 00:30:42     INFO -  Handler.prototype.process@resource://gre/modules/Promise.jsm -> resource://gre/modules/Promise-backend.js:937:23
 00:30:42     INFO -  this.PromiseWalker.walkerLoop@resource://gre/modules/Promise.jsm -> resource://gre/modules/Promise-backend.js:816:7
 00:30:42     INFO -  Promise*this.PromiseWalker.scheduleWalkerLoop@resource://gre/modules/Promise.jsm -> resource://gre/modules/Promise-backend.js:747:11
 00:30:42     INFO -  this.PromiseWalker.schedulePromise@resource://gre/modules/Promise.jsm -> resource://gre/modules/Promise-backend.js:779:7
 00:30:42     INFO -  Promise.prototype.then@resource://gre/modules/Promise.jsm -> resource://gre/modules/Promise-backend.js:454:5
 00:30:42     INFO -  runNextTest@resource://gre/modules/commonjs/toolkit/loader.js -> resource://gre/modules/commonjs/sdk/deprecated/unit-test.js:532:14
 00:30:42     INFO -  startMany@resource://gre/modules/commonjs/toolkit/loader.js -> resource://gre/modules/commonjs/sdk/deprecated/unit-test.js:546:12
 00:30:42     INFO -  findAndRunTests@resource://gre/modules/commonjs/toolkit/loader.js -> resource://gre/modules/commonjs/sdk/test/runner.js:123:5
 00:30:42     INFO -  checkForEnd@resource://gre/modules/commonjs/toolkit/loader.js -> resource://gre/modules/commonjs/sdk/test/harness.js:406:5
 00:30:42     INFO -  nextIteration@resource://gre/modules/commonjs/toolkit/loader.js -> resource://gre/modules/commonjs/sdk/test/harness.js:397:5
 00:30:42     INFO -  runTests@resource://gre/modules/commonjs/toolkit/loader.js -> resource://gre/modules/commonjs/sdk/test/harness.js:618:5
 00:30:42     INFO -  runTests/<@resource://gre/modules/commonjs/toolkit/loader.js -> resource://gre/modules/commonjs/sdk/test/runner.js:42:40
 00:30:42     INFO -  notify@resource://gre/modules/commonjs/toolkit/loader.js -> resource://gre/modules/commonjs/sdk/timers.js:40:9

log: https://treeherder.mozilla.org/logviewer.html#?job_id=16372049&repo=try

This prevents us from enabling that suite in e10s mode on Windows.
M(JP) is permafail across the board, not just Win7.
Summary: [e10s] Jetpack tests permafail on Windows 7 | TypeError: tab is null → [e10s] Jetpack tests permafail with e10s enabled | TypeError: tab is null
andy suggested that you'd resolved most of these since then - just asking as we can close this old march bug out
Flags: needinfo?(lgreco)
should we use this bug to check which tests pass?  and then disable all that do not.  That will detect breakages from this point on.  correcting the test suite issue across the board is a months long effort - that doesn't align with 2017 plans.
Flags: needinfo?(lgreco)
A relevant module owner should sign off on the decision to disable the tests to ensure that we aren't skipping critical functionality in the name of getting *something* reporting to Treeherder. Note that this process was also done for other test suites as part of the effort to get e10s tests enabled across the board.
Status: NEW → RESOLVED
Closed: 3 years ago
Priority: -- → P4
Resolution: --- → DUPLICATE
Whiteboard: triaged
Duplicate of bug: 1232643
You need to log in before you can comment on or make changes to this bug.