Browser: Context Menu 'Save image as ...' does nothing

RESOLVED WORKSFORME

Status

RESOLVED WORKSFORME
3 years ago
2 years ago

People

(Reporter: benl234, Unassigned)

Tracking

({regression, reproducible})

SeaMonkey 2.44 Branch
seamonkey2.44
Unspecified
Windows
regression, reproducible

SeaMonkey Tracking Flags

(seamonkey2.41 affected, seamonkey2.42?, seamonkey2.43?, seamonkey2.44 fixed, seamonkey2.46 fixed)

Details

(Reporter)

Description

3 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:42.0) Gecko/20100101 Firefox/42.0
Build ID: 20160205232941

Steps to reproduce:

I right-clicked on several different images from different webpages and clicked on "Save Image As...."


Actual results:

Nothing happened


Expected results:

A save dialog window should have appeared.  My preference Browser/Downloads/When-saving-a-file is set to "Always ask me where to save files."

If you click "View Image" and choose "Save Page As" from the file menu then you can save the image.

Comment 1

3 years ago
REPRODUCIBLE with inofficial (from <http://seamonkey.callek.net/contrib/>)  en-US Mozilla/5.0 (Windows NT 6.1; WOW64; rv:47.0)  Gecko/20100101 Firefox/47.0 Build 20160205232941  (Default Classic Theme) on on German WIN7 64bit:

1. In Browser open <http://www.seamonkey-project.org/>
2. 'rightclick the SeaMonkey logo above 
   "Web-browser, advanced e-mail, newsgroup and ..." → Save image as ..."'
   Expected: "Save as" file dialog appears
   Actual: Nothing happens

Additional information:
a) Other picture related context menu Items work as expected
b) In the moment when I click 'Save as ..." Error Console tells
   Error: saveImageURL couldn't compute private state of content window
   Source File: chrome://global/content/contentAreaUtils.js
   Line: 159 
c) regression, worked fine with 2.39 (and may be later)
Keywords: regression
OS: Unspecified → Windows
Summary: won't save images → Browser: Context Menu 'Save image as ...' does nothing

Comment 2

3 years ago
d) At first glance "Bug 1243643 - "Save Image As..." Not working" looks similar,
   but in FF after click on "save image as ..." the 'save file' dialog appears
   (but will not save picture),
   whereas in SeaMonkey this dialog does  not appear.
b): "Bug 1246244 - Save Image from the long-press context menu is broken" has 
    the same error message, so this one might be related or even DUP
   
@benl:
Thank you for your attention, really good shot! 
<https://blog.seamonkey-project.org/2016/02/06/dont-ask-what-seamonkey-can-do-for-you-but-what-you-can-do-for-your-seamonkey/>
Keywords: reproducible

Updated

3 years ago
See Also: → bug 1246244
I can confirm this. Fixed if you apply the patch in bug 1246244

User agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:47.0) Gecko/20100101 Firefox/47.0 SeaMonkey/2.44a1
Build identifier: 20160207121535

After the patch only a deprecation warning is shown. We should either close this bug here as a duplicate or use it to track the needed changes (if there isn't already another bug open for this).

Timestamp: 2/7/2016 12:28:36 PM
Error: DEPRECATION WARNING: saveImageURL should be passed the private state of the containing window.
You may find more details about this deprecation at: https://bugzilla.mozilla.org/show_bug.cgi?id=1243643
chrome://global/content/contentAreaUtils.js 143 saveImageURL
chrome://communicator/content/nsContextMenu.js 1112 nsContextMenu.prototype.saveMedia
chrome://navigator/content/navigator.xul 1 oncommand

Source File: resource://gre/modules/Deprecated.jsm
Line: 79

FRG
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Reporter)

Comment 4

3 years ago
User agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:47.0) Gecko/20100101 Firefox/47.0 SeaMonkey/2.44a2
Build identifier: 20160309193908

This bug is for me no longer reproducible with Seamonkey 2.44a2.

The "save image" dialog appears and images are saved.

Comment 5

3 years ago
No longer reproducible  with  English SeaMonkey 2.45a1  (Windows NT 6.1; WOW64; rv:48.0)  Gecko/20100101 Firefox/48.0 Build 20160308001946  (Default Classic Theme)  on German WIN7 64bit.

Any chance to get the (unknown?) fix to next release 2.42?
status-seamonkey2.41: --- → affected
status-seamonkey2.44: --- → fixed
status-seamonkey2.46: --- → fixed
tracking-seamonkey2.42: --- → ?
tracking-seamonkey2.43: --- → ?
Target Milestone: --- → seamonkey2.44
This works in 2.42 and 2.43. It only broke for a short time in 2.44a1 aka FF 47. The bug should imho just be closed.

Comment 7

2 years ago
(In reply to Frank-Rainer Grahl from comment #6)
No longer reproducible with Server-Installation of  unofficial (by FRG) en-US SeaMonkey 2.49a2  (NT 6.1; WOW64; rv:52.0) Gecko/20100101 Firefox/52.0 Build 20161118170316  (Default Classic Theme) on German WIN7 64bit

WFM because FIX currently unknown.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.