bugzilla.mozilla.org has resumed normal operation. Attachments prior to 2014 will be unavailable for a few days. This is tracked in Bug 1475801.
Please report any other irregularities here.

"float:right" looks messy inside <span>-section

RESOLVED WORKSFORME

Status

()

Core
Layout
P4
normal
RESOLVED WORKSFORME
17 years ago
5 years ago

People

(Reporter: Thomas Goerlich, Assigned: Marc Attinasi)

Tracking

Trunk
mozilla1.1alpha
x86
Windows 2000
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

17 years ago
images that are placed inside a "<span>" area will not be displayed at the size
and position as expected when formatted with style="float:right".

structural example #1:
<span>
     <img style="float:right" src="foo.jpg">
</span>

structural example #2:
<span>
     <span style="float:right;">
           <img src="foo.jpg">
     </span>
</span>



i assembled a small demonstration-site (see link above). 

you may have to press "reload" to see the effects.

tried both with mozilla 0.9.8 (win32) and nightly 20020209 (win32)

thanks for doing mozilla. it's a fabulous toy.
I can reproduce the problems on the second and fourth page.

2002-02-08-00, Win32, MathML/SVG.
Can reproduce all three testcases, 2002-02-08-03, Windows 98.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: testcase

Comment 3

17 years ago
I can reproduce the problem in all cases. [Mozilla 2002020908, Windows 2000]
(Reporter)

Comment 4

17 years ago
i did some additional testing on linux:

with 0.9.4, i can reproduce only case #2 (but the image is completely invisible)

with 0.9.8 (build 2002020415), case #2 now looks equal to the win32-screenshot.

the other testcases look okay.

Keywords: testcase

Updated

17 years ago
Target Milestone: --- → mozilla1.1

Updated

17 years ago
QA Contact: petersen → moied

Updated

17 years ago
Priority: -- → P4
This is a dup.. I will hunt for the original....
Whiteboard: DUPEME
Hm.. is the testcase still available?  I forget what the exact HTML code was....
(Reporter)

Comment 7

16 years ago
sorry, tescase is up again
(server moved, guess i forgot to load the testfiles up)

http://www.schnappmatik.de/mozilla/

seems to be fixed in the meantime, anyway! (1.0 win32)
yep, worksforme on a current linux build as well.  Please reopen if this
reappears at some point...
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → WORKSFORME

Updated

5 years ago
Whiteboard: DUPEME
You need to log in before you can comment on or make changes to this bug.