Bluetooth smart beacons fail to enumerate

RESOLVED DUPLICATE of bug 1222956

Status

Firefox OS
Bluetooth
RESOLVED DUPLICATE of bug 1222956
2 years ago
2 years ago

People

(Reporter: MSvB, Assigned: brsun)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

2 years ago
User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:43.0) Gecko/20100101 Firefox/43.0
Build ID: 20160106234723

Steps to reproduce:

Enable Bluetooth in settings, and search for devices. Use an application (like Physical Web [1] or Beacon Scanner [2]) which discovers Bluetooth devices by calling getDefaultAdapter() and startLeScan().

[1] https://github.com/janjongboom/fxos-physical-web/
[2] https://marketplace.firefox.com/addon/system-beacon-scanner/


Actual results:

Applications fail to discover Bluetooth devices. Even worse once an application creates a BluetoothManager object, the 'Search for devices' feature of the 'Bluetooth' settings menu fails to discover Bluetooth devices as well.


Expected results:

Applications using BluetoothManager, getDefaultAdapter, and startLeScan, discover Bluetooth devices. The 'Search for devices' feature of the 'Bluetooth' settings menu discovers and displays Bluetooth devices both before and after mozBluetooth dependent applications run.
(Reporter)

Updated

2 years ago
Summary: Foxfood includes a defective Bluetooth stack → Bluetooth smart beacons fail to enumerate
(Reporter)

Comment 1

2 years ago
An important clue is that BRANCH=v2.5 config.sh downloads correct sources (as far as Bluetooth is concerned) while BRANCH=master config.sh downloads flawed sources.

There's a public video [3] illustrating the proper functioning of Bluetooth APIs on a Xperia Z3C B2G build. This image was built with using v2.5 B2G branch sources, useful for diagnosing or locating the defective block(s) in newer code.

[3] http://1drv.ms/1S8QYxJ
Hi Ben, do you know what might have caused this regression?
Flags: needinfo?(btian)

Comment 3

2 years ago
Settings app works well on discovering and connecting to bluetooth headset with m-c branch. Keep checking physical web and beacon scanner apps.

Comment 4

2 years ago
Assign to Bruce to help on this bug.
Assignee: nobody → brsun

Comment 5

2 years ago
Redirect ni? to Bruce to track.
Flags: needinfo?(btian) → needinfo?(brsun)
(Assignee)

Comment 6

2 years ago
This bug might be the same as bug 1222956.

MsvB: would you mind trying attachment 8719413 [details] [diff] [review] to see if it helps or not?
Flags: needinfo?(brsun) → needinfo?(mozilla)
(Reporter)

Comment 7

2 years ago
(In reply to Bruce Sun [:brsun] from comment #6)
> This bug might be the same as bug 1222956.
>
Could be. If there is a solution to #1222956, we can try applying it to this bug too. Or, if you're sure it's a duplicate then please mark this bug appropriately and close it. Thanks.

> MsvB: would you mind trying attachment 8719413 [details] [diff] [review] to see if it helps or not?
>
No, because the attachment is marked as rejected or obsolete and crossed out.

Thomas found some problems with it and documented them in bug #1222956 I guess? As soon as there's a valid patch I can test it of course
Flags: needinfo?(mozilla)
(Assignee)

Comment 8

2 years ago
After apply the patch on bug 1222956, Beacon Scanner Add-on from :elin can scan nearby LE devices.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1222956
You need to log in before you can comment on or make changes to this bug.