https://test.webrtc.org/ don't return consistent results

RESOLVED WORKSFORME

Status

()

Core
WebRTC
RESOLVED WORKSFORME
2 years ago
2 years ago

People

(Reporter: xavier.combelle, Unassigned)

Tracking

44 Branch
Unspecified
Windows 10
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [needinfo 2016/05/23 to second reporter])

(Reporter)

Description

2 years ago
User Agent: Mozilla/5.0 (Windows NT 10.0; WOW64; rv:44.0) Gecko/20100101 Firefox/44.0
Build ID: 20160123151951

Steps to reproduce:

I was trying to troubleshot facebook video and audio web tchat app on my 
friend computer (windows 10). My friend followed a facebook message on his email inbox which lead to a facebook page where he could launch a voice and video mail

Until I was present his partner did not receive 
neither video or audio from him. He could receive video and audio from his partner

All the other application looks working for video and audio (skype, 
google chrome)

After a bit looking on the problem (press button repair firefox, disable modules, etc.) I eventually made the video working but not audio. I suspected a problem in the webrtc part of firefox.

 I gone on https://test.webrtc.org/ by writting it on the address bar and pressed start 
 and did have pretty strange results (sometimes microphone working and sometimes not )
The result was appears to be random either after restarting or just reloading the page.


Actual results:

My friend chat partner did not received any video intially on facebook

My friend chat partner did never received audio on facebook.

the more frequent result on https://test.webrtc.org/ is the following

Microphone part of the result is red
and by clicking on it the following appear

 Audio capture
[ OK ] Audio track created using device=
[ FAILED ] No active input channels detected. Microphone is most likely muted or broken, please check if muted in the sound settings or physically on the device. Then rerun the test.

but sometimes the microphone part become green
and by clicking on it the following appear
 Audio capture
[ OK ] Audio track created using device=
[ INFO ] Channel 2 levels: -13.9 dB (peak), -32.3 dB (RMS)
[ OK ] Active audio input channels: 1


The firefox navigator console  doesn't show anything looking relevant (except speaking about moz prefixes)

GET 
https://test.webrtc.org/ [HTTP/2.0 304 Not Modified 326 ms]
GET 
https://fonts.googleapis.com/css [HTTP/2.0 200 OK 53 ms]
GET 
https://fonts.googleapis.com/css [HTTP/2.0 200 OK 59 ms]
GET 
https://fonts.googleapis.com/css [HTTP/2.0 200 OK 59 ms]
This appears to be Firefox test.webrtc.org:54:5
mutating the [[Prototype]] of an object will cause your code to run very slowly; instead create the object with the correct initial [[Prototype]] value using Object.create test.webrtc.org:3248:1
GET 
https://www.google-analytics.com/analytics.js [HTTP/2.0 304 Not Modified 39 ms]
navigator.mozGetUserMedia a été remplacé par navigator.mediaDevices.getUserMedia test.webrtc.org:220:11
GET 
https://www.google-analytics.com/collect [HTTP/2.0 200 OK 39 ms]
GET 
https://test.webrtc.org/favicon.ico [HTTP/2.0 200 OK 0 ms]
GET 
https://www.google-analytics.com/collect [HTTP/2.0 200 OK 40 ms]
Les interfaces WebRTC comportant le préfixe « moz » (mozRTCPeerConnection, mozRTCSessionDescription, mozRTCIceCandidate) sont obsolètes. test.webrtc.org:152:11
GET 
https://www.google-analytics.com/collect [HTTP/2.0 200 OK 37 ms]
GET 
https://www.google-analytics.com/collect [HTTP/2.0 200 OK 38 ms]
GET 
https://www.google-analytics.com/collect [HTTP/2.0 200 OK 38 ms]
GET 
https://www.google-analytics.com/collect [HTTP/2.0 200 OK 37 ms]
GET 
XHR 
https://computeengineondemand.appspot.com/turn [HTTP/2.0 200 OK 296 ms]
GET 
https://www.google-analytics.com/collect [HTTP/2.0 200 OK 38 ms]
GET 
XHR 
https://computeengineondemand.appspot.com/turn [HTTP/2.0 200 OK 172 ms]
GET 
https://www.google-analytics.com/collect [HTTP/2.0 200 OK 39 ms]
GET 
https://www.google-analytics.com/collect [HTTP/2.0 200 OK 38 ms]
GET 
XHR 
https://computeengineondemand.appspot.com/turn [HTTP/2.0 200 OK 170 ms]
GET 
https://www.google-analytics.com/collect [HTTP/2.0 200 OK 53 ms]
GET 
XHR 
https://computeengineondemand.appspot.com/turn [HTTP/2.0 200 OK 182 ms]
GET 
https://www.google-analytics.com/collect [HTTP/2.0 200 OK 39 ms]
GET 
https://www.google-analytics.com/collect [HTTP/2.0 200 OK 46 ms]
GET 
XHR 
https://computeengineondemand.appspot.com/turn [HTTP/2.0 200 OK 176 ms]
GET 
https://www.google-analytics.com/collect [HTTP/2.0 200 OK 37 ms]
GET 
XHR 
https://computeengineondemand.appspot.com/turn [HTTP/2.0 200 OK 172 ms]
GET 
https://www.google-analytics.com/collect [HTTP/2.0 200 OK 40 ms]




Expected results:

My friend partner should receive video and audio on facebook tchat.

The microphone part of the http://test.webrtc.org part should be green
(Reporter)

Updated

2 years ago
OS: Unspecified → Windows 10

Updated

2 years ago
Component: Untriaged → WebRTC
Product: Firefox → Core
Facebook recently had a bug in their WebRTC code that caused video-without-audio, when combined with a bug in Firefox 45 and newer.  This bug is in Firefox 45 and later (Firefox Beta (45), Developer Edition (46), and Nightly (47).  This has been fixed in today's Nightly, and will be fixed soon in 45 and 46.  Facebook has fixed their bug as well; I'm not 100% certain they've deployed their fix yet.

Please recheck with Firefox Nightly (https://nightly.firefox.org/)

test.webrtc.org was written targeting Chrome (and Opera), and it may give inconsistent results currently; we're working with them to improve the tests there, and to fix any problems we find along the way.
Flags: needinfo?(xavier.combelle)
(Reporter)

Comment 2

2 years ago
I installed the Nightly in my friend computer and looks like it did not improved the situation for facebook.

Is there some bug tracking entry for the related bug that you said w?
Flags: needinfo?(xavier.combelle)
(Reporter)

Comment 3

2 years ago
Sorry, I accidently clicked on submit here is the complete second sentence

Is there some bug tracking entry for the related bug that you said was fixed?

Comment 4

2 years ago
I made the same experience with several different sites:
- https://apprtc.appspot.com/
- https://chotis2.dit.upm.es/

Always no audio is submitted from firefox to the other participant

https://test.webrtc.org/ always failes with: [ FAILED ] No active input channels detected. Microphone is most likely muted or broken, please check if muted in the sound settings or physically on the device. Then rerun the test. 

All tested with Firefox Nightly 47.0a1 (2016-01-26) for Ubuntu
Does your audio mic work with https://mozilla.github.io/webrtc-landing/gum_test.html?

What mic do you have? What OS, and Firefox version?

Can you provide a log by running with these environment variables:
NSPR_LOG_MODULES=GetUserMedia:4,MediaManager:4,webrtc_trace:65535
WEBRTC_TRACE_FILE=nspr
NSPR_LOG_FILE=some temp log file

Thanks
Flags: needinfo?(xavier.combelle)

Comment 6

2 years ago
Audio not working with new Firefox 46 on the mozilla gum test.
Page says "success" but no echo can be heard.

Logitech Headset, but also not working with internal mic.
OS: Ubuntu 14.04
FF: 45, 46 not working
Nightly: 48.0a1 (2016-04-01) is working

Is this the log you wanted:
[0x7f03aab69580]: D/MediaManager MediaManager: default prefs: 0x0 @30fps (min 10), 1000Hz test tones, aec: on,agc: off, noise: on, aec level: 1, agc level: 1, noise level: 1,playout delay: 50, not full_duplex
[0x7f03aab69580]: D/MediaManager New Media thread for gum
[0x7f0374e03540]: D/GetUserMedia  VoEHardware:GetRecordingDeviceName: Failed -1
[0x7f0374e03540]: D/MediaManager Init: sampling rate 32000
[0x7f0374e03540]: D/MediaManager Init: sampling rate 32000
[0x7f0374e03540]: D/MediaManager Init: sampling rate 32000
[0x7f0374e03540]: D/MediaManager Audio device 0 allocated
[0x7f0374e03540]: D/MediaManager Audio config: aec: 1, agc: -1, noise: 1, delay: 50
[0x7f0374e03540]: D/MediaManager Start audio for stream 7f036f99d980
[0x7f0374e03540]: D/MediaManager started all sources
[0x7f03aab69580]: D/MediaManager Returning success for getUserMedia()
[0x7f03aab69580]: D/MediaManager Listener removed on purpose, mFinished = 1
[0x7f0374e03540]: D/MediaManager Audio device 0 deallocated
[0x7f03aab69580]: D/MediaManager Sent recording-window-ended for window 22 (outer 9)
[0x7f03aab69580]: D/MediaManager Listener removed by DOM Destroy(), mFinished = 1
[0x7f03aab69580]: D/MediaManager OnNavigation for 22
[0x7f03aab69580]: D/MediaManager OnNavigation for 4
[0x7f03aab69580]: D/MediaManager OnNavigation for 21
[0x7f0374e03540]: D/MediaManager MediaManager Thread Shutdown
[0x7f0374e03540]: D/GetUserMedia Shutdown
[0x7f0374e03540]: D/GetUserMedia Shutdown
[0x7f03aab69580]: D/MediaManager MediaManager shutdown lambda running, releasing MediaManager singleton and thread

Updated

2 years ago
Whiteboard: [needinfo 2016/04/18]

Comment 7

2 years ago
So, when I try using https://test.webrtc.org/, I also get intermittent failures for microphone, but the error message is different.

 OK ] Audio track created using device=default: Built-in Microphone (Internal Microphone)
[ INFO ] Channel 2 levels: -64.3 dB (peak), -77.2 dB (RMS)
[ FAILED ] Microphone input level is low, increase input volume or move closer to the microphone.
[ OK ] Active audio input channels: 1

It is quiet in the room I am in, and I suspect that this is actually the same error (just re-worded since this bug was filed, because it was confusing). I would try giving your copy of Firefox some gentle words of encouragement while executing this test, to see if its performance improves.
Alfons -- can you try what Byron suggests in Comment 7?
Flags: needinfo?(Alfons.Martin)
Whiteboard: [needinfo 2016/04/18] → [needinfo to second reporter 2016/05/23]
Whiteboard: [needinfo to second reporter 2016/05/23] → [needinfo 2016/05/23 to second reporter]

Comment 9

2 years ago
I tried it several times while speaking or clapping, but nothing changed.
Even the gum test (https://mozilla.github.io/webrtc-landing/gum_test.html), which should you provide with your own sound with some delay i guess, fails.
Alfons, thanks for following up.

Do you confirm that Firefox 48 is working fine ? Can you try the following steps to help us narrow down the issue:

- Type about:config in the URL bar in Firefox 48 (current Firefox Developer Edition) or 49 (current Firefox Nightly)
- Search for "media.navigator.audio.full_duplex
- Set that to "false"
- Restart Firefox
- Try https://mozilla.github.io/webrtc-landing/gum_test.html again

We have made important changes with our audio input code, and that got enabled in Firefox 48. Setting the preference to "false" reverts to the old code path. It it works with the pref set to "true" but not with the pref set to "false", then we'll have a better understanding of the issue.
Flags: needinfo?(Alfons.Martin)

Comment 11

2 years ago
I installed the Firefox Developer Edition (48.0a2 (2016-05-24)).
Tests https://test.webrtc.org/ and https://mozilla.github.io/webrtc-landing/gum_test.html both working.

Changed to the old code path.
Both tests wont work anymore.

I changed the flag again, both tests work again.

Comment 12

2 years ago
So, whatever the problem is, 48 doesn't seem to have it, and it is way too late to do anything for 47 (if it isn't working there, I don't think anyone here tested it).
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Flags: needinfo?(xavier.combelle)
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.