Closed Bug 1246527 Opened 4 years ago Closed 3 years ago

mozharness cleanup

Categories

(Release Engineering :: Applications: MozharnessCore, defect)

defect
Not set

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1240184

People

(Reporter: aki, Assigned: aki)

References

Details

* unit.sh should call tox instead of nosetests
* flake8 / pyflakes / pylint checks + fixes
* .hgignore
* requirements.txt and requirements-intree.txt

See bug 1244781 for some unlanded work + discussion.
How are you planning to schedule the unit tests automatically? TaskCluster task?
That's the next step, yes.
(In reply to Armen Zambrano [:armenzg] - Engineering productivity from comment #1)
> How are you planning to schedule the unit tests automatically? TaskCluster
> task?

fyi - there is bug 1240184
Depends on: 1240184
I'm going to mark as a dup of 1240184, and if we want followup fixes, we can reopen or file new.
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1240184
You need to log in before you can comment on or make changes to this bug.