Closed Bug 1246571 Opened 4 years ago Closed 4 years ago

Address autofill causes user identification request

Categories

(Firefox :: Address Bar, defect)

43 Branch
x86_64
Windows 10
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 1233982

People

(Reporter: grabarczyk.t, Unassigned)

Details

User Agent: Mozilla/5.0 (Windows NT 10.0; WOW64; rv:43.0) Gecko/20100101 Firefox/43.0
Build ID: 20160105164030

Steps to reproduce:

a site, lets say 'some-site-1.com' requires me to identify myself with a certificate. Because I visit this site frequently, it is being autofilled when I start writing its first letters in the address bar. 



Actual results:

When the url is autofilled it automatically causes the user identification request to pop-up to show, even though I didin't hit enter yet.

This is very annoying and causes problems. For example, when I want to go to 'some-site-2.com' the site 'some-site-1.com' is autofilled and the user identification pops up even though I didn't want to go there. I hit 'cancel' instinctively, and then when I really need go to 'some-site-1.com' I have to restart the browser because I cannot specify my certificate (as I hit cancel before)


Expected results:

address autofill shouldn't cause the user identification request pop up. It should be displayed only when I actually enter the website
Component: Untriaged → Location Bar
OS: Unspecified → Windows 10
Hardware: Unspecified → x86_64
(In reply to grabarczyk.t from comment #0)
> When the url is autofilled it automatically causes the user identification
> request to pop-up to show, even though I didin't hit enter yet.

I think this is bug 1233982, should be fix in Firefox 44. Please let me know.
> I think this is bug 1233982

Yes, it looks like the problem I have. Sorry for duplicating
Status: UNCONFIRMED → RESOLVED
Closed: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1233982
You need to log in before you can comment on or make changes to this bug.