L10n repacks/installers are busted on windows for locales containing a dash

RESOLVED FIXED

Status

defect
P1
blocker
Rank:
10
RESOLVED FIXED
3 years ago
3 years ago

People

(Reporter: standard8, Assigned: standard8)

Tracking

unspecified
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox45 affected, firefox46 fixed)

Details

(Whiteboard: [merge after/at same time as bug 1239828])

Attachments

(2 attachments, 1 obsolete attachment)

Assignee

Description

3 years ago
Following the landing of bug 1239828, L10n repacks are busted on Windows - AFAICT for only locales that have a dash in the locale name:

https://treeherder.mozilla.org/#/jobs?repo=mozilla-central&filter-job_group_symbol=L10n&filter-job_group_symbol=Update-3&filter-job_group_symbol=Update-1&filter-job_group_symbol=Update-2&exclusion_profile=false&revision=76733110704b&selectedJob=3250897

https://treeherder.mozilla.org/logviewer.html#?job_id=3250897&repo=mozilla-central

IOError: [Errno 2] No such file or directory: '../../../dist/xpi-stage/locale-nb-NO/browser\\features/loop@mozilla.org\\chrome\\content/shared/vendor/sdk-content/images/rtc/access-denied-copy-firefox.png'
Seems that weirdo heuristic to use shell or not when executing python process? I recall another bug recently where quoting has helped.
Assignee

Comment 2

3 years ago
I've tried reproducing this locally on my own system, but it runs successfully there.

I'm using:

./mach configure
<copy package/installer files into dist>
cd objdir/browser/locales
compare-locales -m /e/merged/ /e/fx-team/browser/locales/l10n.ini /e/fx-team/l10n-central/ en-GB
mozmake.exe langpack-en-GB LOCALE_MERGEDIR=/e/merged
mozmake.exe installers-en-GB LOCALE_MERGEDIR/e/merged
Assignee

Comment 3

3 years ago
Mike, can you help us here, not being able to reproduce is making it harder for me to guess where we might have got things wrong...
Flags: needinfo?(mh+mozilla)
The best thing to do would be to separate out locales in a separate jar.mn and change the path that browser/locales recurses into. It's actually not a good thing that content and locales are mixed up, that means we're shipping content in langpacks.
Flags: needinfo?(mh+mozilla)
Assignee

Comment 5

3 years ago
Thank you for the suggestion Mike. This does the separation and I've tested it locally on Mac to check it works.

I couldn't reproduce the windows changes, so I'm not sure its worth testing there.
Attachment #8717336 - Flags: review?(mh+mozilla)
Attachment #8717336 - Flags: review?(mh+mozilla) → review+
Assignee

Comment 7

3 years ago
https://treeherder.mozilla.org/#/jobs?repo=mozilla-central&filter-job_group_symbol=L10n&filter-job_group_symbol=Update-3&filter-job_group_symbol=Update-1&filter-job_group_symbol=Update-2&exclusion_profile=false&revision=d1a54ae63da7 looks good now.

Thank you for the hint Mike.
Assignee: nobody → standard8
Status: NEW → RESOLVED
Closed: 3 years ago
Rank: 10
Component: Build Config → Client
Priority: -- → P1
Product: Core → Hello (Loop)
Resolution: --- → FIXED
Version: 33 Branch → unspecified
Assignee

Comment 8

3 years ago
Comment on attachment 8717336 [details] [diff] [review]
Try and fix windows locale repack bustage by adjusting how locales are built for Loop.

Approval Request Comment
[Feature/regressing bug #]: Bug 1239828
[User impact if declined]: Broken L10n repacks on Windows for locales with a dash.
[Describe test coverage new/current, TreeHerder]: Landed in m-c. Passes L10n builds
[Risks and why]: Low, simple build adjustment to bug 1239828
[String/UUID change made/needed]: None
Attachment #8717336 - Flags: approval-mozilla-aurora?
Assignee

Comment 9

3 years ago
Posted patch Patch for beta (obsolete) — Splinter Review
Approval Request Comment

Beta version, please see comment 8 for details.
Attachment #8717546 - Flags: approval-mozilla-beta?
Assignee

Comment 10

3 years ago
Approval Request Comment

Correct patch for beta.
Attachment #8717546 - Attachment is obsolete: true
Attachment #8717546 - Flags: approval-mozilla-beta?
Attachment #8717559 - Flags: approval-mozilla-beta?
Assignee

Updated

3 years ago
Whiteboard: [merge after/at same time as bug 1239828]
Assignee

Updated

3 years ago
Blocks: 1247424
Comment on attachment 8717336 [details] [diff] [review]
Try and fix windows locale repack bustage by adjusting how locales are built for Loop.

Locale build fix for Hello, ok to uplift to aurora.
Attachment #8717336 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Comment on attachment 8717559 [details] [diff] [review]
Patch for beta

Should be in 45 beta 6.
Attachment #8717559 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
Assignee

Updated

3 years ago
Flags: needinfo?(standard8)
backed out by request from sylvestre in https://treeherder.mozilla.org/#/jobs?repo=mozilla-beta&revision=8bf2c5452d44
Flags: needinfo?(standard8)
Assignee

Updated

3 years ago
Flags: needinfo?(standard8)
You need to log in before you can comment on or make changes to this bug.