If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Right-clicking a document on dropbox.com and selecting 'download' - firefox stops responding

RESOLVED INVALID

Status

()

Firefox
Untriaged
--
critical
RESOLVED INVALID
2 years ago
2 years ago

People

(Reporter: Martin Havlista, Unassigned)

Tracking

({hang})

44 Branch
x86_64
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

2 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:43.0) Gecko/20100101 Firefox/43.0
Build ID: 20160105164030

Steps to reproduce:

Go to some dropbox.com account, right click a document and select 'Download'


Actual results:

Firefox 44 stops responding.


Expected results:

It should offer to download a document.
(Reporter)

Updated

2 years ago
Version: 43 Branch → 44 Branch
(Reporter)

Updated

2 years ago
OS: Unspecified → Windows 7
Hardware: Unspecified → x86_64

Comment 1

2 years ago
WFM on Fx45b3 Win10.

https://support.mozilla.org/kb/firefox-hangs-or-not-responding

Updated

2 years ago
Severity: normal → critical
Keywords: hang

Comment 2

2 years ago
Is it reproducible with a clean profile?
https://support.mozilla.org/en-US/kb/profile-manager-create-and-remove-firefox-profiles

In safe mode?
https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode
Flags: needinfo?(xhafan)
(Reporter)

Comment 3

2 years ago
To be honest, I downgraded to version 43.0.4 now where it works fine. 

Just now I upgraded to both 44.0 and 44.0.1 just to check this for you, and firefox would not even load any web site. So I'm sorry, but I cannot check this for you as it's not loading dropbox.com.

Please test it yourself if you can - upload a pdf document to dropbox.com, right click it, and select 'Download'. This was hanging my firefox 44.0.
Flags: needinfo?(xhafan)
Hi Martin,

I have tested this issue on latest Firefox (44.0.1) release and latest Nightly (47.0a1) release and could not reproduce it. I was able to upload a file (any type pdf, txt, jpeg, zip, etc) on Dropbox and download them with no problem. The browser works properly.

Firefox: 44.0.1Build, ID:20160205155049
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:44.0) Gecko/20100101 Firefox/44.0
Firefox: 47.0a1, Build ID: 20160210071115
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:47.0) Gecko/20100101 Firefox/47.0

Can you please test this on latest Nightly build (47.0a1, https://nightly.mozilla.org/) and tell me if this still reproduces for you ? When doing this please use a new fresh Firefox profile as Loic suggested, maybe also in safe mode to eliminate all possible custom settings that could affect(https://support.mozilla.org/en-US/kb/troubleshoot-and-diagnose-firefox-problems). 

Thanks,
Cosmin.
Flags: needinfo?(xhafan)
(Reporter)

Comment 5

2 years ago
This is working for me now in Firefox 44.0.2
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Flags: needinfo?(xhafan)
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.