Non-existent release notes page linked from Firefox Software Update dialogue

RESOLVED FIXED

Status

www.mozilla.org
Release notes
RESOLVED FIXED
2 years ago
2 years ago

People

(Reporter: Tomáš Szaniszlo, Assigned: sylvestre)

Tracking

Production

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

2 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; rv:43.0) Gecko/20100101 Firefox/43.0
Build ID: 20160105164030

Steps to reproduce:

Firefox (version 43.0.4 on Windows) offered me a software update. There is a usual link "View more information about this update" in the update window.


Actual results:

After clicking on the link, it opened in the browser as https://www.mozilla.org/en-US/firefox/44.0.1/releasenotes/ which, however, returned 404 error page. Another interesting thing is that this error page is light gray coloured. On the other hand, I have tried a few intentional modifications of URL resulting in non-existent pages which are all dark gray coloured.


Expected results:

After clicking on the link, a proper release notes page should display.
I guess the page is being prepared.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Flags: needinfo?(rkothari)
Duplicate of this bug: 1246747
(Reporter)

Comment 3

2 years ago
Hm, that might be true. But I think it is somewhat unfortunate timing that the release notes are unavailable when they are most likely to be needed.

Comment 4

2 years ago
(In reply to Kohei Yoshino [:kohei] from comment #1)
> I guess the page is being prepared.

That is so unprofessional. (Not the comment, the situation.) You shouldn't release the product until the documentation is complete. Do you use a checklist prior to release?
I have no idea; I'm not a member of the release engineering team.

Comment 6

2 years ago
(In reply to Kohei Yoshino [:kohei] from comment #5)
> I have no idea; I'm not a member of the release engineering team.

Sorry, I meant does the Firefox release engineering team (whom I assume are following this bug) use a checklist.

As I said in bug 1246747, "IIRC this isn't the first time such a process error has occurred."
(Assignee)

Comment 7

2 years ago
This is fixed now
Assignee: nobody → sledru
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → FIXED

Updated

2 years ago
Flags: needinfo?(rkothari)
You need to log in before you can comment on or make changes to this bug.