Changing the quality on youtube HTML5 video causes screen flicker

RESOLVED WORKSFORME

Status

()

P1
normal
RESOLVED WORKSFORME
3 years ago
2 years ago

People

(Reporter: jonathanshafer3, Unassigned, NeedInfo)

Tracking

47 Branch
x86_64
Windows 10
Points:
---

Firefox Tracking Flags

(platform-rel ?)

Details

(Whiteboard: [platform-rel-Youtube], URL)

(Reporter)

Description

3 years ago
User Agent: Mozilla/5.0 (Windows NT 10.0; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/48.0.2564.97 Safari/537.36

Steps to reproduce:

https://www.youtube.com/watch?v=u2l6nk7pMQ0 Went to that video and a few others to confirm. I went to theater mode. Then I changed the quality of the video and the video started to stutter and flicker other content from the screen over it.


Actual results:

Video Flicker, Stutter, odd behavior when quality was changed via html5 youtube. 


Expected results:

Video should have played normally in spite of changing quality
(Reporter)

Updated

3 years ago
OS: Unspecified → Windows 10
Hardware: Unspecified → x86_64
(Reporter)

Comment 1

3 years ago
Noticed that eventually it would stop. However I also noticed that eventually it would exhibit more unusual behavior. Garbled Graphics, etc.

Updated

3 years ago
Component: Untriaged → Audio/Video: Playback
Product: Firefox → Core

Comment 2

2 years ago
Hi Team,

Hey, I cant reproduce the issue im using the current version.

OS: Windows 7 (64 bits). 
FF: 47.0a2 (2016-04-15)

The issue is not longer displayed, im not sure if someone can confirm that.
Let me know if you need something else. Thanks in advance. Btw great video.

Regards,
Luis Fernandez
Enabling software VP9 support may have hidden hardware decoder issues.
It should be fixed in nightly. Is it still reproducible when you set media.webm.enabled=false ? You can right click and look at "Stats for nerds" to tell whether you're using AVC or VP9.
Priority: -- → P1
Flags: needinfo?(jonathanshafer3)

Updated

2 years ago
platform-rel: --- → ?

Updated

2 years ago
Whiteboard: [platform-rel-Youtube]
I'm going to assume this is fixed in 47 unless I find evidence to the contrary. Feel free to re-open if the issue still exists.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.