Status

defect
RESOLVED FIXED
3 years ago
Last year

People

(Reporter: glandium, Assigned: glandium)

Tracking

unspecified
mozilla47
Dependency tree / graph

Firefox Tracking Flags

(firefox47 fixed)

Details

Attachments

(1 attachment)

Assignee

Description

3 years ago
No description provided.
Assignee

Comment 1

3 years ago
msys-perl-wrapper was used to transform windows paths after the -I flag,
which was a preprocessor flag, which a) doesn't exist anymore and b) the
preprocessor has not even be in perl for years.
Attachment #8717371 - Flags: review?(mshal)
Attachment #8717371 - Flags: review?(mshal) → review+

Comment 3

3 years ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/e70ca6fb89d8
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla47
Could this be the cause for Bug 1247282? Starting with the 2016-02-10 nightly builds the comm-central Windows builds report an error when invoking perl scripts.
Assignee

Comment 5

3 years ago
Yes, it is, but I'm not thrilled to back out just for comm-central.

Updated

3 years ago
Depends on: 1247282
Blocks: 1247282
No longer depends on: 1247282
Just in case you didn't read it in the other bugs, no problem in not backing this out. We've temporarily added the msys-perl-wrapper in comm-central and I will soon rewrite those scripts in python.

Updated

Last year
Product: Core → Firefox Build System
You need to log in before you can comment on or make changes to this bug.