[Ubuntu] ”Share my geolocation” button is not displayed on Google Maps

RESOLVED WORKSFORME

Status

Tech Evangelism
Desktop
RESOLVED WORKSFORME
2 years ago
a year ago

People

(Reporter: Vasilica Mihasca, QA [away for an extended period of time - please needinfo addonsqa@softvision.ro], Unassigned)

Tracking

Trunk
x86_64
Linux

Firefox Tracking Flags

(firefox44 affected, firefox45 affected, firefox46 affected, firefox47 affected)

Details

(Whiteboard: [country-all] [needsdiagnosis], URL)

[Affected versions]:
Firefox 44 RC build 3
Firefox 45 Beta 3 
Firefox 46.0a2 (2016-02-08)
Firefox 47.0a1 (2016-02-08)

[Affected platforms]:
Ubuntu 12.04 64-bit


[Steps to reproduce]:
1.Launch Firefox with clean profile.
2.Navigate to https://www.google.ro/maps
3.Check the “Show my location” button.

[Expected Results]:
“Show my location” button is successfully displayed for Google Maps. ( http://i.imgur.com/kxoVZCZ.png  )

[Actual Results]:
“Show my location” button misses from Google maps.
See screenshot: http://i.imgur.com/voqZBA4.png


[Additional notes]:
- This issue is not reproducible under Windows and Mac platforms.
- This issue is not a regression.

Comment 1

2 years ago
UA spoofing like following fixes the problem.
general.useragent.override = Mozilla/5.0 (Windows NT 6.1; WOW64; rv:47.0) Gecko/20100101 Firefox/47.0

So, this is Google's problem.

Updated

2 years ago
Component: Geolocation → Desktop
Product: Core → Tech Evangelism

Comment 2

2 years ago
Vasilica, thanks for the bug.

What was your initial User Agent String?
Flags: needinfo?(vasilica.mihasca)

Updated

2 years ago
Whiteboard: [country-all] [needsdiagnosis]
(In reply to Karl Dubost :karlcow from comment #2)

> What was your initial User Agent String?

Mozilla/5.0 (X11; Linux x86_64; rv:45.0) Gecko/20100101 Firefox/45.0
Flags: needinfo?(vasilica.mihasca)
Hi Vasilica, does this still reproduce for you? I just tested and the button is visible for me in Nightly and Dev Edition on Ubutntu (and it finds my location when I click it).
Flags: needinfo?(vasilica.mihasca)
I apologize for the delay here, Mike -- this is on our todo list, we'll follow up as soon as possible.
Flags: needinfo?(vasilica.mihasca) → needinfo?(andrei.vaida)
This is no longer reproducible on either affected or fixed builds. We
used Ubuntu 12.04 x86, 12.04 x64 and 16.04 x64, with:
    - 46.0a2 (2016-02-08)
    - 47.0a1 (2016-02-08)
    - 48.0 (20160726073904)
    - 49.0b2-build1 (20160808002253)
    - 50.0a2 (2016-08-10)
    - 51.0a1 (2016-08-10)

I think this might've been fixed on Google's side, either way, it's 
no longer reproducible.
Flags: needinfo?(andrei.vaida)
Thank you for checking, Andrei! Closing this issue.
Status: NEW → RESOLVED
Last Resolved: a year ago
Resolution: --- → WORKSFORME
Yep, thanks!
You need to log in before you can comment on or make changes to this bug.