[e10s] Various Windows-specific content process graphics leaks

RESOLVED DUPLICATE of bug 1252677

Status

()

Core
Graphics
RESOLVED DUPLICATE of bug 1252677
2 years ago
2 years ago

People

(Reporter: mccr8, Unassigned)

Tracking

(Blocks: 1 bug, {mlk})

Trunk
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(e10s+, firefox47 affected)

Details

(Whiteboard: [MemShrink:P1],gfx-noted,perf)

(Reporter)

Description

2 years ago
In bug 1219919, I landed some additional suppressions for Windows-specific content process leaks, beyond those with are required for Linux and OSX. 

The suppressions I added are in this commit: https://hg.mozilla.org/mozilla-central/rev/3885c33f2013

The first block of suppressions (1 AsyncTransactionTrackersHolder, 1 CompositableChild, 1 Mutex, 1 PCompositableChild, 1 PImageContainerChild, 1 SyncObject, 2 WeakReference<MessageListener>) show up in all content processes, and look related to ImageBridgeChild, so they don't really need much additional investigation.

The leaks in the second block of suppressions vary from test suite to test suite (including things like DXGID3D9TextureData and RemoveTextureFromCompositableTracker), so they may indicate real leaks. I included some information in the suppression list about what tests these seem to show up in.

To reproduce these second leaks, you need the patch in bug 1219369 and to delete some or all of the suppressions from 3885c33f2013, so they show up.

This is probably a number of leaks, so maybe it is better to treat this as a meta-bug, and file bugs for specific leaks against this.
(Reporter)

Updated

2 years ago
tracking-e10s: --- → ?
Milan, how do you want to handle this?
Flags: needinfo?(milan)
(In reply to Brad Lassey [:blassey] (use needinfo?) from comment #1)
> Milan, how do you want to handle this?

In bug 1232549.  Except that it just got marked as a duplicate of another one, so I'll reset it back.
Flags: needinfo?(milan)
Whiteboard: [MemShrink] → [MemShrink],gfx-noted,perf
Whiteboard: [MemShrink],gfx-noted,perf → [MemShrink:P1],gfx-noted,perf
Flags: needinfo?(gwright)
Milan thinks this is a dupe of bug 1232549, so let's track the other one for e10s and then revisit this and verify whether it's still an issue after 1232549 is fixed.
Flags: needinfo?(gwright)

Updated

2 years ago
Blocks: 993639
tracking-e10s: ? → +
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1252677
You need to log in before you can comment on or make changes to this bug.