Plugincheck not seeing new Flash version when updating Flash while browser is running with e10s

RESOLVED DUPLICATE of bug 1090576

Status

()

P2
normal
RESOLVED DUPLICATE of bug 1090576
3 years ago
2 years ago

People

(Reporter: bzbarsky, Unassigned)

Tracking

({regression})

Trunk
regression
Points:
---

Firefox Tracking Flags

(e10s+, firefox47 affected)

Details

Attachments

(1 attachment)

STEPS TO REPRODUCE:
1)  Ensure you have an old version of Flash.
2)  Ensure you are running e10s.
3)  Load https://www.mozilla.org/en-US/plugincheck/
4)  Observe the old version being listed.
5)  Update Flash from https://get.adobe.com/flashplayer/
6)  Reload https://www.mozilla.org/en-US/plugincheck/
7)  Observe the old version is still being listed.
8)  Open https://www.mozilla.org/en-US/plugincheck/ in a non-e10s window.
9)  Observe the new version of Flash is now listed.
10) Reload https://www.mozilla.org/en-US/plugincheck/ in the e10s window.
11) Observe the new version of Flash is now listed.

The incorrect thing here is step 7: it should list the new version of Flash.

Mossop suspects that navigator.plugins.refresh may not do the right thing in a child process.
bz, did you restart the browser as part of the Flash update process?  The process asks you to restart browser.  Perhaps step 8 is acting like a restarted browser?

I could not reproduce this if restarting the browser as instructed.

Mac 10.11.2, Nightly 47.0a1, 20160209030347 - WFM
Windows 7, Nightly 47.0a1, 20160208030244 - WFM
Ubuntu 14.04.2, Nightly 47.0a1, 20160209030347 - WFM
(Reporter)

Comment 2

3 years ago
> bz, did you restart the browser as part of the Flash update process?

No.  If I had, it would have been in the steps to reproduce.  ;)

> The process asks you to restart browser.

I'm aware of that, but we don't actually need to do that in non-e10s, and restarting our browser is enough of a PITA that we shouldn't require it if we don't have to.

> Perhaps step 8 is acting like a restarted browser?

It's possible, but more likely it actually correctly rescans plugins....
tracking-e10s: ? → +
Priority: -- → P4
QA Update: reference the attached and "ni" if I can provide further testing or assistance. I could reproduce original. (No browser restart and the plugin check page retained old info.) I then check about:addons and observed the info was displayed accurately. I returned to the plugin check page and then I was able to refresh and see the info correctly displayed.
Flags: needinfo?(blassey.bugs)
Created attachment 8793856 [details]
OldFlashBug1247042.rtf
no more testing needed, this looks to be triaged and confirmed correctly
Flags: needinfo?(blassey.bugs)

Comment 6

2 years ago
And a duplicate. Although we should not be triaging this so low: it's a regression that could bite us pretty bad in the event of Flash 0-day updates. Not plugincheck in particular, but any site like youtube that does Flash version checks and alerts users to update.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Keywords: regression
Priority: P4 → P2
Resolution: --- → DUPLICATE
Duplicate of bug: 1090576
You need to log in before you can comment on or make changes to this bug.