[traceback] TypeError: In order to allow non-dict objects to be serialized set the safe parameter to False

RESOLVED DUPLICATE of bug 1201709

Status

Mozilla Developer Network
General
--
major
RESOLVED DUPLICATE of bug 1201709
2 years ago
2 years ago

People

(Reporter: stephend, Unassigned)

Tracking

({in-triage})

Details

(URL)

(Reporter)

Description

2 years ago
https://developer.mozilla.org/en-US/docs/MDN/User_guide$children throws:

TypeError: In order to allow non-dict objects to be serialized set the safe parameter to False

Traceback (most recent call last):
File "/data/www/developer.mozilla.org/venv/lib/python2.7/site-packages/newrelic-2.52.0.40/newrelic/api/web_transaction.py", line 711, in __iter__
File "/data/www/developer.mozilla.org/venv/lib/python2.7/site-packages/newrelic-2.52.0.40/newrelic/api/web_transaction.py", line 1087, in __call__
File "/data/www/developer.mozilla.org/venv/lib/python2.7/site-packages/django/core/handlers/wsgi.py", line 189, in __call__
File "/data/www/developer.mozilla.org/venv/lib/python2.7/site-packages/django/core/handlers/base.py", line 132, in get_response
File "/data/www/developer.mozilla.org/venv/lib/python2.7/site-packages/newrelic-2.52.0.40/newrelic/hooks/framework_django.py", line 499, in wrapper
File "/data/www/developer.mozilla.org/kuma/kuma/core/decorators.py", line 155, in agent_blocked_view
File "/data/www/developer.mozilla.org/venv/lib/python2.7/site-packages/django/views/decorators/http.py", line 45, in inner
File "/data/www/developer.mozilla.org/kuma/kuma/wiki/decorators.py", line 31, in _added_header
File "/data/www/developer.mozilla.org/kuma/kuma/wiki/decorators.py", line 106, in process
File "/data/www/developer.mozilla.org/kuma/kuma/wiki/views/document.py", line 268, in children
File "/data/www/developer.mozilla.org/venv/lib/python2.7/site-packages/django/http/response.py", line 532, in __init__


Sentry: https://sentry.prod.mozaws.net/operations/mdn-prod/group/222484/
New Relic: https://rpm.newrelic.com/accounts/263620/applications/3172075/traced_errors/3066f1-15fa677a-cf7e-11e5-ad22-c81f66b8ceca
Keywords: in-triage
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1201709
You need to log in before you can comment on or make changes to this bug.